Bug 905 - Makefile broken on Solaris due to PICSUFFIX changes
Makefile broken on Solaris due to PICSUFFIX changes
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.1
All Solaris
: P1 critical
: none
Assigned To: Tim Potter
:
: 662 (view as bug list)
Depends on: 662
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-12-19 12:26 UTC by Brian Poole
Modified: 2005-08-24 10:21 UTC (History)
2 users (show)

See Also:


Attachments
I failed to reproduce the bug (103 bytes, text/plain)
2003-12-22 05:41 UTC, David S. Collier-Brown
no flags Details
Full configure & build log showing failure (48.12 KB, text/plain)
2003-12-22 15:26 UTC, Brian Poole
no flags Details
Patch removing the workaround that is causing build failure (1.73 KB, patch)
2003-12-30 08:26 UTC, Brian Poole
no flags Details
Possible patch for the problem (283 bytes, patch)
2004-01-08 15:47 UTC, Jelmer Vernooij
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Poole 2003-12-19 12:26:19 UTC
Assigning to tpot@samba.org as thats who committed the changes which appear to
have caused this problem:

As reported on samba-technical, Samba does not currently compile with the Forte
compiler:

The 3.0.1 source does not compile currently on Solaris. My testing
environment was using the Forte compiler & Sun make. The problem is
in the Makefile where it tries to move some non-existent files.
This can be seen on the Samba build farm:

http://build.samba.org/?function=View+Build&host=sun1&tree=samba_3_0&compiler=cc

The error looks like:

mv: cannot access nsswitch/wb_common.po.o.o
make: *** [nsswitch/wb_common.po.o] Error 2

The output file is of course not wb_common.po.o.o, but
wb_common.po.o. Should be a relatively simple patch but I am unsure
of what the correct destination name is, so I did not make a patch.
If you just change the source name it would try to move
wb_common.po.o to wb_common.po.o and error out because they are the
same file.

This error occurs three times in the Makefile.in and was introduced
2 months ago when PICSUFFIX was added:

http://cvs.samba.org/cgi-bin/cvsweb/samba/source/Makefile.in.diff?r1=1.721&r2=1.722
Comment 1 David S. Collier-Brown 2003-12-22 05:41:26 UTC
Created attachment 334 [details]
I failed to reproduce the bug

I tried 3.0.1 production with both sun make and gmake 3.74.
The Sun CC used was Forte Developer 7 C 5.4 2002/03/09
all on Solaris 8 Generic_108528-17
Regrettably, I couldn't reproduce the bug.

I'll see if I can find a later version of Forte 7

--dave
Comment 2 Brian Poole 2003-12-22 15:26:47 UTC
Created attachment 337 [details]
Full configure & build log showing failure

Curious.. I can see it on a Solaris 9 machine with the same Forte compiler you
have. Problem occurs with the Solaris make and with GNU Make (3.80). Problem
does not occur with GCC3 (but of course I don't want to use gcc ;-).

cc: Forte Developer 7 C 5.4 2002/03/09
SunOS hostnameremoved 5.9 Generic_112233-08 sun4u sparc SUNW,Sun-Blade-100

I can also reproduce the problem on Solaris 7 & Solaris 8 using an older Forte
compiler (also independent of which make used.)

cc: WorkShop Compilers 5.0 98/12/15 C 5.0

I've attached the configure & build logfile for the Solaris 9 attempt when
using Solaris' make. The logs are nearly identical for the important part on
Solaris 7 & Solaris 8 so I haven't attached those.

The log was made from: (./configure && make) >/tmp/samba-sol9-make-forte.log
2>&1
No special options and a pretty clean Solaris 9 install.
Comment 3 Brian Poole 2003-12-30 08:26:47 UTC
Created attachment 344 [details]
Patch removing the workaround that is causing build failure

This patch removes a workaround that causes the build to fail when using the
Forte compiler. I'm uncertain as to whether or not the workaround is still
necessary, especially with old versions of Solaris/Forte. Hopefully someone
more familiar with the workaround can comment. This was tested on Solaris 7
with WorkShop Compilers 5.0 98/12/15 C 5.0.
Comment 4 Gerald (Jerry) Carter 2004-01-07 11:28:11 UTC
*** Bug 452 has been marked as a duplicate of this bug. ***
Comment 5 Jelmer Vernooij 2004-01-08 15:02:35 UTC
*** Bug 662 has been marked as a duplicate of this bug. ***
Comment 6 Tim Potter 2004-01-08 15:31:22 UTC
Richard made the POBAD_CC change over two years ago.  Maybe it's time to remove
it?  I'm not sure we have access to the old compiler that this change was
applicable to.  Whatever the problem was it looks like it's fixed in more modern
compiler versions.

Revision 1.191 / (download) - annotate - [select for diffs] , Mon Jul 23
11:22:29 2001 UTC (2 years, 5 months ago) by sharpe
Branch: MAIN
Changes since 1.190: +11 -1 lines
Diff to previous 1.190 (colored)

Fix the POOBAD_CC on Slowaris so we can handle things correctly ...

Lets see how this goes.

Revision 1.316 / (download) - annotate - [select for diffs] , Mon Jul 23
11:22:29 2001 UTC (2 years, 5 months ago) by sharpe
Branch: MAIN
Changes since 1.315: +2 -2 lines
Diff to previous 1.315 (colored)

Fix the POOBAD_CC on Slowaris so we can handle things correctly ...

Lets see how this goes.
Comment 7 Jelmer Vernooij 2004-01-08 15:47:12 UTC
Created attachment 354 [details]
Possible patch for the problem

Wouldn't the following patch be sufficient to fix this? It's not the most
elegant solution, though.
Comment 8 Tim Potter 2004-01-08 16:47:14 UTC
Yes that would fix it, although it would leave the crufty POBAD_CC code lying
around.  It would be nicer to remove this if it doesn't serve its purpose anymore.
Comment 9 Tim Potter 2004-01-14 22:53:56 UTC
I have committed a fix based on attachment 334 [details] (there was some extra POBAD_CC in
the examples/VFS directory).
Comment 10 Gerald (Jerry) Carter 2005-08-24 10:21:08 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.