Bug 662 - Configure.in defines POBAD_CC="" on Solaris, it should be left as "#"
Configure.in defines POBAD_CC="" on Solaris, it should be left as "#"
Status: RESOLVED DUPLICATE of bug 905
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Jelmer Vernooij
:
Depends on:
Blocks: 905
  Show dependency treegraph
 
Reported: 2003-10-21 10:20 UTC by Eric Boehm
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Boehm 2003-10-21 10:20:08 UTC
I am having problems with the build on Solaris 8.

POBAD_CC is being defined as "" on solaris, causing the following rule to be
executed

@mv $*.po.o.o $@

resulting in the error

Compiling nsswitch/wb_common.c with -KPIC
mv: cannot access nsswitch/wb_common.po.o.o
*** Error code 2
make: Fatal error: Command failed for target `nsswitch/wb_common.po.o'


This rule is not necessary


Possible patch is

--- configure.in.orig   Tue Oct 21 09:13:53 2003
+++ configure.in        Tue Oct 21 13:17:54 2003
@@ -1067,7 +1067,6 @@
                                ## ${CFLAGS} added for building 64-bit shared 
                                ## libs using Sun's Compiler
                                LDSHFLAGS="-G \${CFLAGS}"
-                               POBAD_CC=""
                                PICSUFFIX="po.o"
                        fi
                        AC_DEFINE(STAT_ST_BLOCKSIZE,512,[The size of a block])
Comment 1 Jelmer Vernooij 2004-01-08 15:02:34 UTC

*** This bug has been marked as a duplicate of 905 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:29:57 UTC
database cleanup