Bug 8954 - From Windows 8 Beta browsing a share on S4 + S3FS is not working
From Windows 8 Beta browsing a share on S4 + S3FS is not working
Product: Samba 4.0
Classification: Unclassified
Component: Other
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Depends on:
Blocks: 8622
  Show dependency treegraph
Reported: 2012-05-23 06:46 UTC by Matthieu Patou
Modified: 2012-10-22 13:47 UTC (History)
2 users (show)

See Also:

Capture (63.86 KB, application/vnd.tcpdump.pcap)
2012-05-23 08:26 UTC, Matthieu Patou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2012-05-23 06:46:08 UTC
Given a s4 server with s3fs enabled, I try to browse a share from Windows 8 beta and it's not working.

I try net use t: // totoTATA123 /user:MATWS\administrator it's also not working.

The same with ntvfs is ok.

Problem seems to be that the IOCTL request is never answered.
Comment 1 Stefan Metzmacher 2012-05-23 08:11:13 UTC
captures and level 10 logs please:-)
Comment 2 Matthieu Patou 2012-05-23 08:26:27 UTC
Created attachment 7583 [details]

Capture, log level 10 tomorrow
Comment 3 Stefan Metzmacher 2012-05-23 08:38:01 UTC
Do you have this patch?
Comment 4 Stefan Metzmacher 2012-08-12 15:04:02 UTC
Ping, does that still not work with current master?
Comment 5 Matthieu Patou 2012-08-14 09:00:02 UTC
let me retry in a couple of days.
Comment 6 Stefan Metzmacher 2012-10-22 13:47:07 UTC
(In reply to comment #5)
> let me retry in a couple of days.

With Windows Server 2012 it works fine for me.

Matthieu please reopen if you still see this problem with
current Samba and Windows versions.