Bug 895 - Samba 3.0.1 SRPM fails to build on Red Hat 7.1
Samba 3.0.1 SRPM fails to build on Red Hat 7.1
Status: RESOLVED DUPLICATE of bug 879
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 11:53 UTC by Ambrose Li
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ambrose Li 2003-12-16 11:53:11 UTC
Doing an rpm-build --rebuild of the SRPM on Red Hat 7.1 gives the following
error message. Looking at the source, the quotas.c file is falling into the
"else" (LINUX_QUOTAS_2) case, but the system actually has a struct dqblk
(LINUX_QUOTAS_1), not a struct mem_dqblk.

[stuff deleted]
Compiling smbd/vfs-wrap.c
Compiling smbd/statcache.c
Compiling smbd/posix_acls.c
Compiling lib/sysacls.c
Compiling lib/server_mutex.c
Compiling smbd/process.c
Compiling smbd/service.c
Compiling smbd/error.c
Compiling printing/printfsp.c
Compiling lib/sysquotas.c
Compiling smbd/change_trust_pw.c
Compiling smbd/fake_file.c
Compiling smbd/quotas.c
smbd/quotas.c: In function `get_smb_linux_vfs_quota':
smbd/quotas.c:135: storage size of `D' isn't known
make: *** [smbd/quotas.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.45700 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.45700 (%build)
Comment 1 Gerald (Jerry) Carter 2003-12-16 13:04:37 UTC
Are you using a stock kernel ?  Or did you build 
you own?  This sounds like a mismatch between the glibc 
kernel headers and the actual running kernel headers.
Comment 2 Gerald (Jerry) Carter 2003-12-16 13:32:44 UTC

*** This bug has been marked as a duplicate of 879 ***
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:24:04 UTC
database cleanup