Bug 879 - compiling smbd/quotas.c failed
compiling smbd/quotas.c failed
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
All Linux
: P3 normal
: none
Assigned To: Tim Potter
:
: 895 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 10:35 UTC by Ronan SALMON
Modified: 2005-11-14 09:25 UTC (History)
2 users (show)

See Also:


Attachments
quota.h file from kernel 2.4.20 (6.93 KB, text/plain)
2003-12-12 04:51 UTC, Ronan SALMON
no flags Details
samba-3.0.1rc2/source/include/config.h (53.01 KB, text/plain)
2003-12-12 07:15 UTC, Ronan SALMON
no flags Details
configure output (30.67 KB, text/plain)
2003-12-12 07:50 UTC, Ronan SALMON
no flags Details
samba-3.0.1rc2/source/config.log (374.13 KB, text/plain)
2003-12-12 08:29 UTC, Ronan SALMON
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronan SALMON 2003-12-11 10:35:02 UTC
samba-3.0.1rc2.src.rpm
kernel-2.4.20-8
redhat 9 i386
quota-3.06-9

./configure --prefix=/usr --localstatedir=/var --with-configdir=/etc/samba
--with-privatedir=/etc/samba --with-fhs --with-quotas --with-smbmount --with-pam
--with-pam_smbpass --with-syslog --with-utmp --enable-cups --with-ldap
--with-ldapsam --with-acl-support --with-sambabook=/usr/share/swat/using_samba
--with-swatdir=/usr/share/swat --with-libsmbclient

...

Compiling lib/afs.c
smbd/quotas.c: In function `get_smb_linux_vfs_quota':
smbd/quotas.c:135: storage size of `D' isn't known
make: *** [smbd/quotas.o] Error 1
make: *** Waiting for unfinished jobs....
error: Bad exit status from /var/tmp/rpm-tmp.31652 (%build)


I was able to compile samba-3.0.1pre3 without a problem. I didn't try
samba-3.0.1rc1 because I can't find the SRPM on samba.org servers.

Ronan
Comment 1 Tim Potter 2003-12-11 16:19:56 UTC
Metze, I remember you saying that this was a header file/glibc problem but the
poster here sounds like he has a pretty simple system.  What gives?
Comment 2 Stefan Metzmacher 2003-12-12 04:25:43 UTC
Ronan,

can you give me the output of configure
and your /usr/include/linux/quota.h

Tim, I'm working on porting the samba2.2 samba_linux_quota.h to samba3.0
which should clean up all the linux quota mess.
But it's not completely finished yet:-(

metze
Comment 3 Ronan SALMON 2003-12-12 04:50:12 UTC
/usr/include/linux is a link to /usr/src/linux/include/linux

I'll post the file anyway.
Comment 4 Ronan SALMON 2003-12-12 04:51:50 UTC
Created attachment 320 [details]
quota.h file from kernel 2.4.20
Comment 5 Stefan Metzmacher 2003-12-12 05:53:34 UTC
Version: $Id: quota.h,v 2.0 1996/11/17 16:48:14 mvw Exp mvw $

This is not the quota.h from the 2.4.20 kernel!
and that's what make the trouble...

Can you give me your configure output and source/include/config.h too, please


Comment 6 Ronan SALMON 2003-12-12 07:15:13 UTC
Created attachment 321 [details]
samba-3.0.1rc2/source/include/config.h
Comment 7 Ronan SALMON 2003-12-12 07:41:53 UTC
I ran diff on a fresh kernel 2.4.20 from kernel.org and the one I have and the
two quota files are the exact same.

[~/kernel]#diff linux-2.4.20/include/linux/quota.h
/usr/src/linux/include/linux/quota.h
[~/kernel]#
Comment 8 Ronan SALMON 2003-12-12 07:50:55 UTC
Created attachment 322 [details]
configure output
Comment 9 Ronan SALMON 2003-12-12 08:29:05 UTC
Created attachment 323 [details]
samba-3.0.1rc2/source/config.log
Comment 10 Gerald (Jerry) Carter 2003-12-16 13:32:45 UTC
*** Bug 895 has been marked as a duplicate of this bug. ***
Comment 11 Stefan Metzmacher 2004-01-08 01:59:19 UTC
can you try 3.0.2pre1, it should be fixed there
Comment 12 Ronan SALMON 2004-01-12 03:58:48 UTC
3.0.2pre1 does compile.
Thanks.
Comment 13 Ronan SALMON 2004-01-12 04:00:15 UTC
I can't close the bug but I guess it can be closed since I can compile.
Comment 14 Stefan Metzmacher 2004-01-12 09:52:35 UTC
does it only compile or does it also work correct?

what is when some one is over quota, is the free disk space displayed 
correct...?
Comment 15 Tim Potter 2004-01-12 14:49:09 UTC
Marking as fixed.
Comment 16 Ronan SALMON 2004-01-14 01:29:10 UTC
In reply to Comment #14

It seems to be working properly. Free space is displayed/updated correctly.
Comment 17 Gerald (Jerry) Carter 2005-08-24 10:21:53 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 18 Gerald (Jerry) Carter 2005-11-14 09:25:25 UTC
database cleanup