Bug 8876 - Should we still support libwbclient as fixed ABI (do we support other implementations?)
Should we still support libwbclient as fixed ABI (do we support other impleme...
Status: RESOLVED WONTFIX
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
All All
: P5 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks: 8622
  Show dependency treegraph
 
Reported: 2012-04-18 12:50 UTC by Stefan Metzmacher
Modified: 2012-06-06 06:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2012-04-18 12:50:38 UTC
Should we still support libwbclient as fixed ABI (do we support other implementations?)

See the discussion on IRC:
https://irclog.samba.org/lifefeed.log
https://irclog.samba.org/2012/04/20120418-Wed.log
Comment 1 Andrew Bartlett 2012-06-06 06:52:43 UTC
The decision, as I recall it, is not to support foreign libwbclient implementations until we have someone make a specific proposal.  We already use extra features not (presumably) in the likewise one. 

(The specific issue that brought this up was from packages needing to package Samba4 with Samba3 on the system, and we came up with a way to just make the Samba4 libwbclient private then, as it was only for torture)