Bug 8649 - waf options aren't fully supported
waf options aren't fully supported
Status: RESOLVED DUPLICATE of bug 8969
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
All All
: P5 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks: 8622
  Show dependency treegraph
 
Reported: 2011-12-07 13:14 UTC by Andreas Schneider
Modified: 2012-11-06 11:14 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2011-12-07 13:14:48 UTC
There are waf option which have bugs or are not fully supported as it looks like.

pam_smbpass is build by default.

We have an option:

  --with-pam_smbpass
            Build with pam_smbpass support

but there is no option do disable it. So these options should take an argument and display a default in the help:

  --with-pam_smbpass=yes
  --with-pam_smbpass=no

or there should be an option

  --without-pam_smbpass
Comment 1 Guenther Deschner 2011-12-07 13:18:56 UTC
(In reply to comment #0)
> There are waf option which have bugs or are not fully supported as it looks
> like.
> 
> pam_smbpass is build by default.
> 
> We have an option:
> 
>   --with-pam_smbpass
>             Build with pam_smbpass support
> 
> but there is no option do disable it. So these options should take an argument
> and display a default in the help:
> 
>   --with-pam_smbpass=yes
>   --with-pam_smbpass=no
> 
> or there should be an option
> 
>   --without-pam_smbpass

There is this option, look at buildtools/wafsamba/samba3.py the SAMBA3_ADD_OPTION definition, it's just as it has no effect:


    #FIXME: This is broken and will always default to "default" no matter if
    # --with or --without is chosen.
Comment 2 Matthias Dieter Wallnöfer 2012-05-04 08:37:33 UTC
Günther,
is there a way to fix this? Who is the right assignee?
Comment 3 Karolin Seeger 2012-11-06 10:46:18 UTC
Andreas, is this still an issue?
If yes, would you like to provide a patch?
Comment 4 Karolin Seeger 2012-11-06 11:14:13 UTC

*** This bug has been marked as a duplicate of bug 8969 ***