Bug 851 - build-failure on x86_64 (VFS-modules)
build-failure on x86_64 (VFS-modules)
Status: VERIFIED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
Other Linux
: P3 normal
: none
Assigned To: Tim Potter
:
: 2060 (view as bug list)
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-12-03 14:57 UTC by Guenther Deschner
Modified: 2005-02-08 03:47 UTC (History)
1 user (show)

See Also:


Attachments
propsed patch for building modules on x86_64 (541 bytes, patch)
2003-12-03 14:59 UTC, Guenther Deschner
no flags Details
Fix build system in examples/VFS (2.07 KB, patch)
2003-12-05 03:42 UTC, Tim Potter
no flags Details
Extra file needed (854 bytes, text/plain)
2003-12-05 03:44 UTC, Tim Potter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2003-12-03 14:57:25 UTC
samba3 (current CVS) can not be build on x64_64:

Linking shadow_copy_test.so
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.1/../../../../x86_64-suse-linux/bin/ld:
shadow_copy_test.o: relocation R_X86_64_32 can not be used when making a
shared object; recompile with -fPIC

just compiling with fPIC solves the problem for me.
Comment 1 Guenther Deschner 2003-12-03 14:59:48 UTC
Created attachment 298 [details]
propsed patch for building modules on x86_64
Comment 2 Guenther Deschner 2003-12-04 02:39:56 UTC
please note that building on x86_64 in general works well (although i have not
yet tested the binaries).

the error pops up just with "make modules"
Comment 3 Tim Potter 2003-12-05 03:42:58 UTC
Created attachment 301 [details]
Fix build system in examples/VFS

OK it looks like the build system in the examples/VFS directory is pretty
broken.  This patch tries to fix it.  It seems to work on i386.  Please test on
x86_64!

You will need to copy config.sub and config.guess from the ../../source
directory.
Comment 4 Tim Potter 2003-12-05 03:44:20 UTC
Created attachment 302 [details]
Extra file needed

You'll also need this fragment of m4 code from ../../source in the examples/VFS
directory.
Comment 5 Guenther Deschner 2004-11-19 16:33:17 UTC
*** Bug 2060 has been marked as a duplicate of this bug. ***
Comment 6 Gerald (Jerry) Carter 2005-02-07 10:48:47 UTC
still an issue guenther ?  
Comment 7 Lars Müller 2005-02-08 03:47:14 UTC
This is fixed at least with 3.0.11.

...
+ /usr/bin/make
Compiling shadow_copy_test.c
Linking shadow_copy_test.so
Compiling skel_opaque.c
Linking skel_opaque.so
...