Bug 8457 - The GPFS and VFS_PREALLOC VFS modules need additional include files
The GPFS and VFS_PREALLOC VFS modules need additional include files
Status: RESOLVED DUPLICATE of bug 8363
Product: Samba 3.6
Classification: Unclassified
Component: VFS Modules
3.6.0
All All
: P5 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 18:59 UTC by Richard Sharpe
Modified: 2011-10-20 10:59 UTC (History)
0 users

See Also:


Attachments
Patch ... (1015 bytes, application/octet-stream)
2011-09-14 18:59 UTC, Richard Sharpe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Sharpe 2011-09-14 18:59:01 UTC
Created attachment 6890 [details]
Patch ...

Trying to build all modules on 3.6.0 fails when building GPFS and VFS_PREALLOC.

They both need to include system/filesys.h.

A git format-patch fix is attached.
Comment 1 Richard Sharpe 2011-09-14 18:59:40 UTC
This is the simple fix:

From 87fdc5248726a78771f57b5fb691e1edd4fb20f8 Mon Sep 17 00:00:00 2001
From: Richard Sharpe <realrichardsharpe@gmail.com>
Date: Mon, 12 Sep 2011 11:39:13 -0700
Subject: [PATCH] Add a missing include file to two VFS modules
Signed-off-by: Richard Sharpe <realrichardsharpe@gmail.com>

---
 source3/modules/gpfs.c         |    1 +
 source3/modules/vfs_prealloc.c |    1 +
 2 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/source3/modules/gpfs.c b/source3/modules/gpfs.c
index d690199..c9ab9bf 100644
--- a/source3/modules/gpfs.c
+++ b/source3/modules/gpfs.c
@@ -19,6 +19,7 @@
 
 #include "includes.h"
 #include "smbd/smbd.h"
+#include "system/filesys.h"
 
 #ifdef HAVE_GPFS
 
diff --git a/source3/modules/vfs_prealloc.c b/source3/modules/vfs_prealloc.c
index 4d1b2e1..20f21a6 100644
--- a/source3/modules/vfs_prealloc.c
+++ b/source3/modules/vfs_prealloc.c
@@ -19,6 +19,7 @@
 
 #include "includes.h"
 #include "smbd/smbd.h"
+#include "system/filesys.h"
 
 /* Extent preallocation module.
  *
-- 
1.7.1
Comment 2 Björn Jacke 2011-10-20 10:59:29 UTC
thanks for your report, both of these have already been fixed for 3.6.1.

*** This bug has been marked as a duplicate of bug 8363 ***