Bug 8451 - 3.6.0 net join failure
3.6.0 net join failure
Product: Samba 3.6
Classification: Unclassified
Component: Client Tools
Sparc Solaris
: P5 normal
: ---
Assigned To: Volker Lendecke
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2011-09-12 17:54 UTC by Tom Schulz
Modified: 2012-12-20 11:03 UTC (History)
3 users (show)

See Also:

smb.comf (7.62 KB, text/plain)
2012-02-13 15:25 UTC, Tom Schulz
no flags Details
smb.conf.mackerel included from smb.conf (534 bytes, application/octet-stream)
2012-02-13 15:27 UTC, Tom Schulz
no flags Details
debug output with -W and -S specified (54.77 KB, application/octet-stream)
2012-02-13 15:30 UTC, Tom Schulz
no flags Details
debug output without -W and -S (3.26 KB, text/plain)
2012-02-13 15:37 UTC, Tom Schulz
no flags Details
debug output with -W and -S specified as type text/plain (54.77 KB, text/plain)
2012-02-13 15:43 UTC, Tom Schulz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Schulz 2011-09-12 17:54:15 UTC
I built Samba 3.6.0 on a Solaris 8 Sparc box. We are using it with a Windows Server 2000 domain controller. When I issue the following command:

./net join member -W adi -U administrator%password -S starfish2

I get the following error.

Could not connect to server starfish2
The username or password was not correct.
Connection failed: NT_STATUS_LOGON_FAILURE

I tried it without the %password and let it prompt me for the password and got the same error message. The net command from Samba 3.5.11 works, so I can work around the problem for now.
Comment 1 Tom Schulz 2011-09-12 18:09:25 UTC
The following is not really part of this bug, but I think that I should note it here. The reason I was doing the net join is because after upgrading from Samba 3.5.11 to 3.6.0 the Samba server could no longer get user account information from the domain controller.I found that if I deleted the machines account on the domain controller and then rejoined the domain, the Samba server now worked correctly. Fortunately the 3.5.11 net command worked and made the 3.6.0 server happy. The original net join was probably done with a version of Samba prior to version 3.0.
Comment 2 Tom Schulz 2011-12-08 16:31:22 UTC
This problem still exists in Samba 3.6.1. The net join command does work with the newly released Samba 3.5.12. Since this bug was reported, I have built Samba on a Solaris 10 I386 box that we recently got. The same problems exists and I had to build both 3.6.1.and 3.5.12 to be able to use this machine.
Comment 3 Tom Schulz 2012-02-08 16:57:55 UTC
The problem still exists in Samba 3.6.3. I still have to keep Samba 3.5.12 around to do a net join.
Comment 4 Michael Adam 2012-02-13 11:48:20 UTC

could you please provide your smb.conf?

As well as the complete output of failing "net join -d10 ..." ?

And could you try to not specify -W and -S on the command line?
(instead info should be taken from the smb.conf).

If it was not for the attempt to specify it on the command line,
I would have guessed this was a duplicate of bug #8729.

But that is only affecting interactive password entry.
So it must be something different.

Comment 5 Tom Schulz 2012-02-13 15:25:22 UTC
Created attachment 7314 [details]
Comment 6 Tom Schulz 2012-02-13 15:27:33 UTC
Created attachment 7315 [details]
smb.conf.mackerel included from smb.conf
Comment 7 Tom Schulz 2012-02-13 15:30:51 UTC
Created attachment 7316 [details]
debug output with -W and -S specified
Comment 8 Tom Schulz 2012-02-13 15:37:13 UTC
Created attachment 7317 [details]
debug output without -W and -S

I hope that all the attachments are good. Note that running net join without the -W and -S does not get the required information from smb.conf. This behavior is the same as with version 3.5.12.
Comment 9 Tom Schulz 2012-02-13 15:43:25 UTC
Created attachment 7318 [details]
debug output with -W and -S specified as type text/plain

attachment forcing type text/plain
Comment 10 Michael Adam 2012-02-16 22:56:27 UTC
The attachments look good.
I need to find some time to take a closer look...
Stay tuned.
Comment 11 Tom Schulz 2012-11-08 15:33:05 UTC
The problem still exists with Samba 3.6.8.
Comment 12 Tom Schulz 2012-12-18 16:38:26 UTC
Fixed in Samba 3.6.10
I expect that the fix is a side effect of one of the following:
    * BUG 9272: 'net ads join' does not provide AES keys in host keytab.
    * BUG 9326: Fix 'net ads join' message for the dns domain.
    * BUG 8966: Fix 'net rpc share allowedusers' to work with 2008r2.
Comment 13 Karolin Seeger 2012-12-20 11:03:05 UTC
Closing out bug report.
Tom, thanks a lot for your feedback! :-)