Bug 8729 - getpass regressions on Solaris/Illumos - 3.6 and master
getpass regressions on Solaris/Illumos - 3.6 and master
Status: RESOLVED FIXED
Product: Samba 3.6
Classification: Unclassified
Component: Client Tools
3.6.3
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 8386 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 12:20 UTC by Ira Cooper
Modified: 2012-05-16 07:01 UTC (History)
3 users (show)

See Also:


Attachments
git-am fix for 3.6.next. (1.58 KB, patch)
2012-01-31 23:37 UTC, Jeremy Allison
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ira Cooper 2012-01-30 12:20:26 UTC
There's been at least 2 regressions on the Solaris platforms.  One involving net join not working, and one involving smbclient not working, using typed passwords.

I ended up tracking this issue down via bisection to: 510e61871c0c2b2659b80d5f785522184131b1d9 and then working out why that patch was the issue.

If you look at the commit involved, it looks like a no-op.  Alas, util.c included "system/passwd.h" and util_cmdline.c did not, so there was a regression, because getpass doesn't take passwords longer than 8 characters, on Solaris.

I'm looking for a better idea than just adding "system/passwd.h" to source3/include/includes.h, that also has the effect of protecting against the kind of simple mistake made in the commit above.  I can't blame the committer for the error, it was far too easy to make, in my opinion.

Patch enclosed, and verified to work, against v3-6-test, that just adds "system/passwd.h" to source3/include/includes.h.

Thanks for the explanation of the brokenness of getpass on Solaris, Andrew Bartlett.

-Ira
Comment 1 Jeremy Allison 2012-01-31 23:37:00 UTC
Created attachment 7275 [details]
git-am fix for 3.6.next.

Ira's git-am fix applied to master for 3.6.next.

Jeremy.
Comment 2 Stefan Metzmacher 2012-02-01 07:18:48 UTC
Comment on attachment 7275 [details]
git-am fix for 3.6.next.

looks good
Comment 3 Stefan Metzmacher 2012-02-01 07:19:20 UTC
Karolin, please for the next release
Comment 4 Karolin Seeger 2012-02-03 19:28:50 UTC
Pushed to v3-6-test.
Closing out bug report.

Thanks!
Comment 5 Stefan Metzmacher 2012-05-16 07:01:50 UTC
*** Bug 8386 has been marked as a duplicate of this bug. ***