Bug 821 - smbclient Version 3.0.0 to 3.0.1pre3 can't connect to OS/2 Server
smbclient Version 3.0.0 to 3.0.1pre3 can't connect to OS/2 Server
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.0
All OS/2
: P3 normal
: none
Assigned To: Steve French
:
: 772 (view as bug list)
Depends on:
Blocks: 1353
  Show dependency treegraph
 
Reported: 2003-11-26 04:49 UTC by Michael Suelmann
Modified: 2005-10-12 13:13 UTC (History)
2 users (show)

See Also:


Attachments
fix to allow smbclient for samba 3 and later to access pre-NTLM servers such as OS2 (640 bytes, patch)
2003-12-03 15:40 UTC, Steve French
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Suelmann 2003-11-26 04:49:47 UTC
smbclient -L HOST   and  smbclient //HOST/SHARE fail with
NT code 0x00050002 with samba-3.0.x if HOST is running 0S/2

Tested with samba-3.0.0 and 3.0.1pre3 on RedHat 9 (RPM from samba.org) and Suse
8.1/SLES 8/UnitedLinux (self-compiled)
Server: OS/2 Warp 3 IPG 8596 or OS/2 Warp 4.52 IPG8605
Comment 1 Michael Suelmann 2003-11-26 23:06:46 UTC
smbclient from samba-2.2.8a works
Comment 2 Gerald (Jerry) Carter 2003-11-27 06:48:43 UTC
jim, do you still have an OS/2 test machine?  Can you take 
a look at this ?  Thanks.
Comment 3 Steve French 2003-12-03 08:24:43 UTC
Yes - the problem is that smbclient is now sending a sessionsetup with 
incorrect format for sessionsetup (sending a post lanman12 style bcc area) and 
is sending the userid in unicode which is leading to access denied (return code 
5) which is also being incorrectly interpreted as an NT status code.
Comment 4 Steve French 2003-12-03 15:40:49 UTC
Created attachment 299 [details]
fix to allow smbclient for samba 3 and later to access pre-NTLM servers such as OS2
Comment 5 Luc Lalonde 2003-12-04 11:39:44 UTC
I've tested Samba-3.0.0 to Samba-3.0.1rc3 with the same results.

If you need tests to be done please contact me.  We still have a 
couple of OS/2 machines running here...
Comment 6 Luc Lalonde 2003-12-05 12:00:51 UTC
Tested Samba-3.0.1rc1 with the same bug...
Comment 7 Gerald (Jerry) Carter 2003-12-12 08:36:30 UTC
*** Bug 772 has been marked as a duplicate of this bug. ***
Comment 8 Gerald (Jerry) Carter 2004-03-12 08:27:15 UTC
Steve, are we any better now ?
Comment 9 Gerald (Jerry) Carter 2005-02-08 21:39:21 UTC
retest against 3.0.11 and reopen if necessary.  Thanks.
Comment 10 Gerald (Jerry) Carter 2005-08-24 10:28:22 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.