Bug 772 - Windows for workgroups servers unavailable
Windows for workgroups servers unavailable
Status: RESOLVED DUPLICATE of bug 821
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Linux
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 10:42 UTC by Nicolas Trécourt
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Trécourt 2003-11-13 10:42:36 UTC
This report can be quite funny, since this "os" is not very widely used nowadays
:) but I have some strange behaviour with samba 3 and wfw311.
I noticed two problems, one of them is just a little annoying, and the second is
more blocking.

It seems that the long filename algorithm has changed sin samba v2, and when
using my wfw311 clients names seems completely random :).

The second configuration, wfw311 server and samba 3 client, is more blocking.
The identification is good, It is possible to mount shares and connect with
smbclient.
But directory content listing fails. smbclient only show an empty directory,
smbmount give this message:

ls: reading directory /mnt/slot0: Input/output error

In both case, transferts on both ways are possible and works well (in the
second, it assume i know the filename :) ).
Comment 1 Gerald (Jerry) Carter 2003-12-12 08:36:29 UTC
to correct the first issue (name mangling), set 
mangling method = hash to store the 2.2. behavior.

The second part is actually a duplicate of bug 821.  I'm closing 
this one and adding you to the CC list on that bug.

*** This bug has been marked as a duplicate of 821 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:31:40 UTC
database cleanup