Bug 806 - testparm seems to have default for passwd program "" instead of /bin/passwd
testparm seems to have default for passwd program "" instead of /bin/passwd
Status: RESOLVED DUPLICATE of bug 805
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.0preX
All All
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 08:36 UTC by Clock
Modified: 2005-02-07 08:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clock 2003-11-24 08:36:59 UTC
testparm /usr/local/samba/lib/smb.conf

ERROR: the 'unix password sync' parameter is set and the 'passwd program' () cannot be executed (error was No such file or directory)

When I add "passwd program /bin/passwd" into smb.conf, the error message disappears.

man smb.conf: passwd program: default: passwd program = /bin/passwd
Comment 1 Tim Potter 2003-11-25 15:14:50 UTC

*** This bug has been marked as a duplicate of 805 ***
Comment 2 Gerald (Jerry) Carter 2005-02-07 08:41:29 UTC
originally reported against 3.0.0beta3.  CLeaning out 
non-production release versions.