Bug 8009 - net rap session cannot get username
net rap session cannot get username
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Client Tools
3.5.4
IA64 HP-UX
: P5 minor
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 6473 6474 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-11 14:03 UTC by nathalie.petro
Modified: 2011-03-17 14:28 UTC (History)
2 users (show)

See Also:


Attachments
mode debug level 10 (38.07 KB, text/plain)
2011-03-11 14:03 UTC, nathalie.petro
no flags Details
Patch (756 bytes, patch)
2011-03-12 09:56 UTC, Volker Lendecke
no flags Details
Fix for 3.5.x. (970 bytes, patch)
2011-03-14 17:49 UTC, Jeremy Allison
vl: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nathalie.petro 2011-03-11 14:03:18 UTC
Created attachment 6285 [details]
mode debug level 10

net rap session doesn't display username and Client Type

F7HC_root:/> /usr/local/samba/bin/net rap session -U eidinst%admin
Computer             User name            Client Type        Opens Idle time
------------------------------------------------------------------------------
\\f7hc                                                          0 00:00:00
Comment 1 Volker Lendecke 2011-03-12 09:56:09 UTC
Created attachment 6286 [details]
Patch

The attached patch fixes it for me.
Comment 2 nathalie.petro 2011-03-14 09:59:26 UTC
(In reply to comment #1)
> Created attachment 6286 [details]
> Patch
> The attached patch fixes it for me.

This patch fixes it for me too.
Can you tell me when this correction will be included in a next version ?

Thank you.
Comment 3 Jeremy Allison 2011-03-14 17:49:23 UTC
Created attachment 6288 [details]
Fix for 3.5.x.

Same fix with different commit message :-). Volker, please check and re-assign to Karolin  for inclusion in 3.5.next.
Cheers,
Jeremy.
Comment 4 Karolin Seeger 2011-03-17 14:15:05 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Created attachment 6286 [details] [details]
> > Patch
> > The attached patch fixes it for me.
> 
> This patch fixes it for me too.
> Can you tell me when this correction will be included in a next version ?
> 
> Thank you.

Fix will be included in Samba 3.5.9.
Comment 5 Karolin Seeger 2011-03-17 14:15:32 UTC
Pushed to v3-5-test.
Closing out bug report.

Thanks!
Comment 6 Guenther Deschner 2011-03-17 14:27:19 UTC
*** Bug 6473 has been marked as a duplicate of this bug. ***
Comment 7 Guenther Deschner 2011-03-17 14:28:48 UTC
*** Bug 6474 has been marked as a duplicate of this bug. ***