Bug 7948 - Build system: ldb.pc wrongly installed from samba4 build
Build system: ldb.pc wrongly installed from samba4 build
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Jelmer Vernooij
samba4-qa@samba.org
:
: 7947 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-07 09:17 UTC by Sean Finney
Modified: 2011-03-17 12:09 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Finney 2011-02-07 09:17:06 UTC
(note that this problem existed before the top-level build chagnes today)

the install target for samba4 by default includes a .pc file for libldb.  this .pc file should not be installed with samba4 (which wants to have a private libldb).  

Additionally, the .pc file does not include the lib dir and rpath options for the "private" directory, meaning that other projects will pick up the .pc file and assume that libldb is installed, but will fail to build/link with unresolved symbols into the ldb build.

The suggested fix is to not install the .pc file, except when building/installing from the source4/lib/ldb directory (which is what I think was actually the intention, anyway).
Comment 1 Sean Finney 2011-02-07 09:19:43 UTC
*** Bug 7947 has been marked as a duplicate of this bug. ***
Comment 2 Sean Finney 2011-02-07 09:20:40 UTC
There are likely other .pc files with the same problem, such as the python/ldb bindings.
Comment 3 Matthias Dieter Wallnöfer 2011-02-07 09:34:24 UTC
Jelmer, do you have an opinion?
Comment 4 Jelmer Vernooij 2011-02-07 09:40:52 UTC
I'll have a look at fixing this.
Comment 5 Matthias Dieter Wallnöfer 2011-02-09 07:10:06 UTC
Has this now been fixed? Can I close it?
Comment 6 Matthias Dieter Wallnöfer 2011-03-17 09:41:34 UTC
Sean, I really think that this has been fixed by metze:
http://gitweb.samba.org/samba.git/?p=samba.git;a=commitdiff;h=1d5f3c11df95b9a4f846a7122d1aab354a42dd3a
Comment 7 Sean Finney 2011-03-17 12:09:48 UTC
Sorry I thought you were asking Jelmer, not me, whether it was fixed.  Everything has seemed fine here for a while :)