Bug 7947 - build failure: /usr/bin/ld: cannot find -lpyldb-util
build failure: /usr/bin/ld: cannot find -lpyldb-util
Status: RESOLVED DUPLICATE of bug 7948
Product: Samba 4.0
Classification: Unclassified
Component: Build
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Andrew Tridgell
samba4-qa@samba.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-04 02:42 UTC by Sean Finney
Modified: 2011-02-07 09:19 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Finney 2011-02-04 02:42:18 UTC
./autogen.sh && env PKG_CONFIG_PATH=/opt/gnome/lib64/pkgconfig ./configure  --prefix=/opt/gnome --libdir=/opt/gnome/lib64 && make -j4 && make install 

<snip>

[2147/2262] Linking default/source4/dsdb/python-dsdb.so
/usr/bin/ld: cannot find -lpyldb-util
collect2: ld returned 1 exit status
Waf: Leaving directory `/home/CORPUSERS/23059934/checkout/gnome/samba4/source4/bin'
Build failed:  -> task failed (err #1): 
	{task: cc_link pydsdb_20.o -> python-dsdb.so}
make: *** [all] Error 1

In case it's relevant, i'm attempting to install on top of an existing samba4 installation (also from git master, maybe 2 days ago).
Comment 1 Sean Finney 2011-02-04 02:56:51 UTC
okay, I don't speak WAF very well, but it seems that it might be detecting the pyldb-util from the previous installation and attempting to use that, and failing.

The failure seems to be becuase the previous version didn't isntall a libpyldb-util.so symlink pointing at the actual shared library, and the subsequent build found the .pc file and assumed that meant to build against "the system version" of the library.
Comment 2 Sean Finney 2011-02-07 09:19:43 UTC
oh, i think this is actually the same problem as the next bug I reported (Bug #7948) and thus i'll close this one and mark it duplicate of the next one.

*** This bug has been marked as a duplicate of bug 7948 ***