Bug 7786 - Upload of driver is impossible
Upload of driver is impossible
Status: NEW
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.6
x86 Windows 2003
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 04:44 UTC by Stephan Hector
Modified: 2010-11-10 04:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Hector 2010-11-10 04:44:20 UTC
As decribed here:
https://bugzilla.samba.org/show_bug.cgi?id=7445
i can't upload a driver over a Win2003 or WinXP box.

Our Samba is a PDC installed on Debian Squeeze (Kernel 2.6.32-5-686), Samba-Version is 2:3.5.6~dfsg-1, which is 3.5.6. For printing, cups is used (1.4.4-3)

Passdb-Backend of Samba is a LDAP-Server in a different VM, but this works together fine (Shares are all working, all logins are working, getent works, ...).

If I go to a Win2003 machine, log in as user domain/administrator, which is mapped to root, browse to our Samba, open printer section, right click printer -> properties -> say no to driver install -> advanced -> add new driver -> search driver -> click finish

Looking into /samba/drivers/W32X86 i see files appear, propably driver files and then they are deleted and i get message "Access denied" in win2003 box.

As i read, files should be copied to /samba/drivers/W32X86/3, but they aren't.

Looking in smbstatus when copying driver files, I see, that I come in as user root with uid 0, but get deny_all or deny_write as deny_mode.

Printer is a Dell 2330 dn which worked fine before update and sure it's shared in cups.

print$ from smb.conf:
[print$]
   comment = Printer Driver Download Area
   path = /samba/drivers
   browseable = yes
   guest ok = no
   read only = yes
   write list = root, shector, @lpadmin, "@Domain Admins"

I also tried it with "use privileges = yes" and granted rights to root and shector (which is me) by following command:
net rpc rights grant "domain\root" SePrintOperatorPrivilege -U domain/root
and
net rpc rights grant "domain\root" SePrintOperatorPrivilege -U host/root

Nothing helped.

If needed, I can provide configs and logfiles, but please specify which one you need :)

Thx in advance
Stephan