Bug 7445 - Unable to upload printer drivers
Unable to upload printer drivers
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.6
x64 Windows XP
: P3 major
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 12:56 UTC by Marc Muehlfeld
Modified: 2014-05-15 08:31 UTC (History)
2 users (show)

See Also:


Attachments
Level 10 debug log of the failed copy process (332.39 KB, application/octet-stream)
2010-05-20 12:57 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2010-05-20 12:56:22 UTC
If I try to upload printer drivers on the server via a Windows client, I get errors on several files ("can't copy"). E. g. "SN0HGC.DL_"

It seems that the file should be copied to the wrong directory:

[2010/05/20 19:44:03,  5] smbd/filename.c:564(unix_convert)
  New file SN0HGC.DLL
[2010/05/20 19:44:03,  8] lib/util.c:1683(is_in_path)
  is_in_path: W32X86/SN0HGC.DLL
[2010/05/20 19:44:03,  8] lib/util.c:1707(is_in_path)
  is_in_path: match not found
[2010/05/20 19:44:03,  3] smbd/vfs.c:865(check_reduced_name)
  reduce_name [W32X86/SN0HGC.DLL] [/shares/Printer]
[2010/05/20 19:44:03, 10] smbd/vfs.c:937(check_reduced_name)
  reduce_name realpath [W32X86/SN0HGC.DLL] -> [/shares/Printer/W32X86/SN0HGC.DLL]
[2010/05/20 19:44:03,  3] smbd/vfs.c:974(check_reduced_name)
  reduce_name: W32X86/SN0HGC.DLL reduced to /shares/Printer/W32X86/SN0HGC.DLL
[2010/05/20 19:44:03,  3] smbd/trans2.c:4050(call_trans2qfilepathinfo)
  call_trans2qfilepathinfo: SMB_VFS_STAT of W32X86/SN0HGC.DLL failed (No such file or directory)
[2010/05/20 19:44:03,  3] smbd/error.c:153(reply_unix_error)
  unix_error_packet: error string = No such file or directory
[2010/05/20 19:44:03,  3] smbd/error.c:60(error_packet_set)
  error packet at smbd/trans2.c(4051) cmd=50 (SMBtrans2) NT_STATUS_OBJECT_NAME_NOT_FOUND



I tried uploading Sharp MX 2600n PS v.0909a driver.
Comment 1 Marc Muehlfeld 2010-05-20 12:57:01 UTC
Created attachment 5724 [details]
Level 10 debug log of the failed copy process
Comment 2 Marc Muehlfeld 2010-09-09 08:32:28 UTC
This bug is fixed in 3.5.4 (haven't tested 3.4.x any more).
Comment 3 Stephan Hector 2010-11-10 04:04:36 UTC
Bug isn't fixed. I have the same problem in 3.5.6 on Debian Squeeze.

If I try to upload a driver over a Win2003 or WinXP Box, I always get a "access denied". Looking where it tries to store the files, they are put in W32X86 directly, not in W32X86/3 as described here.

If you need a complete log, i'll try to deliver it, also if you need smb.conf and/or cupsd.conf.

greetings
Stephan
Comment 4 Marc Muehlfeld 2010-11-12 10:42:37 UTC
You are right. It still exists. I can confirm on 3.5.6 too.
Comment 5 Marc Muehlfeld 2012-11-14 21:26:57 UTC
I currently use 3.5.19 and updated printer drivers during the last 5 weeks (so 3.5.18 should be fine, too). And here I don't had any problems uploading drivers from XP and Win7.
Comment 6 Marc Muehlfeld 2013-05-08 15:49:49 UTC
I can successfully upload a driver for a new printer with 3.6.13. So it seems fixed in at least in the 3.6 tree (don't have 3.5 any more).
Comment 7 Marc Muehlfeld 2014-05-15 08:31:00 UTC
Im closing this bug report, as it works since 3.6.13