Bug 7672 - Ability to include (source) other files into the rsncd.conf configuration.
Ability to include (source) other files into the rsncd.conf configuration.
Status: RESOLVED DUPLICATE of bug 7633
Product: rsync
Classification: Unclassified
Component: core
All All
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2010-09-10 09:18 UTC by Brian Gregg
Modified: 2010-09-10 20:34 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Brian Gregg 2010-09-10 09:18:54 UTC
Forgive me if this has been suggested before, but I didn't see this in the Bug database.

Being that we use rsync to transfer web log files from each of our Apache instances to our central web log server, it would be nice to be able to say use an Include or Source statement in the main rsyncd.conf file which would reference other subordinate rsyncd.conf files such as in the following example.  This would allow us to individually modify each virtual instances rsyncd.conf file separately but still maintain the main /etc/rsyncd.conf file.  This would be similar to the Apache "Include" statement in their configuration files.  The statements in the included files would be same that are used in the main /etc/rsyncd.conf.  Preferably a quick validation check on the included file would take place to ensure that it is syntactically correct before invoking it, otherwise drop it from being included and log a message about it.  The format of the "Include" can be changed to what ever you see fit as I see there is already an 'include' stanza already present.  Maybe the use of "Source" would be a better statement.  I believe that this would be of value to others that are hosting a large number of systems that wish to dynamically wish to update their main /etc/rsyncd.conf file but keep parts of the configuration separate.

I hope that you find this a fairly good addition to your software.

# Global
log file = /var/adm/rsyncd.log
pid file = /var/run/rsyncd.pid
use chroot = yes
uid = nobody
gid = nobody
max connections = 10
read only = yes
timeout = 60
transfer logging = yes

#Include external file
Include: /usr/local/apache/vhost1/rsyncd.conf
Include: /usr/local/apache/vhost2/rsyncd.conf
Include: /usr/local/apache/vhost3/rsyncd.conf
Source: /usr/local/apache/vhost4/rsyncd.conf

Thank you,
Brian Gregg
University of Pittsburgh
University Library System.
Comment 1 Carlos Carvalho 2010-09-10 13:08:55 UTC
This feature is already implemented in the development (3.1) version.
Comment 2 Wayne Davison 2010-09-10 20:34:49 UTC
See the 3.1.0dev version for this feature.  e.g. snag the git version, or a "nightly" tar file.

*** This bug has been marked as a duplicate of bug 7633 ***