Bug 7633 - add support for include/includedir config file directives
add support for include/includedir config file directives
Status: RESOLVED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.1.0
Other All
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
: 7672 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 14:07 UTC by Neil Katin
Modified: 2010-09-10 20:34 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Katin 2010-08-19 14:07:19 UTC
The samba configuration has support for including an external configuration file into the smb.conf file.

rsync does not support this functionality.

I'm requesting this functionality so rsync server configurations can be
modularly changed without having to edit the "main" file, by dropping other
config files into a directory and having the main config file reference them.

At some level this is just syntactic sugar: I could just combine all the
other files together at run time.  But it would be convenient if rsync
provided the functionality natively.
Comment 1 Wayne Davison 2010-08-21 12:57:29 UTC
See the CONFIG DIRECTIVES section of the rsyncd.conf manpage in 3.1.0.  At work we use "&include /etc/rsyncd.d" inside a simple /etc/rsyncd.conf file so we can put whatever module-defining *.conf files we like inside that directory.
Comment 2 Wayne Davison 2010-09-10 20:34:49 UTC
*** Bug 7672 has been marked as a duplicate of this bug. ***