Bug 7643 - Unable to execute "rpcclient setdriver"
Unable to execute "rpcclient setdriver"
Status: RESOLVED DUPLICATE of bug 7277
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.2
x64 Linux
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 17:11 UTC by Nelson Chan
Modified: 2010-08-24 03:14 UTC (History)
0 users

See Also:


Attachments
Command output with debuglevel=10 (67.14 KB, text/plain)
2010-08-23 17:13 UTC, Nelson Chan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nelson Chan 2010-08-23 17:11:03 UTC
I run Samba 3.5.2 in CentOS 5.5 x64.  The samba environment works fine until I try to add a printer driver into samba.

The driver was added successfully using "adddriver".  "enumdrivers" shows the driver and "enumprinters" shows the printer.

But when I try to execute "setdriver":

rpcclient -Uroot -c 'setdriver Cups-PDF mspubprtc' srv1test

I get the following messages:

cli_pipe_validate_current_pdu: RPC fault code DCERPC_FAULT_OP_RNG_ERROR received from host srv1test!
Successfully set Cups-PDF to driver mspubprtc.
cli_pipe_validate_current_pdu: RPC fault code DCERPC_FAULT_OP_RNG_ERROR received from host srv1test!

Even it says the driver is set successfully, no driver is shown up when I execute "getprinter".
Comment 1 Nelson Chan 2010-08-23 17:13:21 UTC
Created attachment 5919 [details]
Command output with debuglevel=10

Uploaded the command output with "--debuglevel=10"
Comment 2 Guenther Deschner 2010-08-24 03:14:24 UTC
This got fixed in 3.5.3

*** This bug has been marked as a duplicate of bug 7277 ***