Bug 7277 - Some Trouble with printing under Samba 3.5.1
Some Trouble with printing under Samba 3.5.1
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.1
x64 Windows XP
: P3 regression
: ---
Assigned To: Stefan Metzmacher
Samba QA Contact
:
: 7363 7643 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-22 07:35 UTC by Richard Lamboj
Modified: 2010-08-24 03:14 UTC (History)
2 users (show)

See Also:


Attachments
patch for 3.5 (2.20 KB, patch)
2010-05-03 09:35 UTC, Guenther Deschner
metze: review+
Details
patch for 3.4 (2.20 KB, patch)
2010-05-03 09:36 UTC, Guenther Deschner
metze: review+
Details
followup patch for 3.4 (17.41 KB, patch)
2010-05-04 03:54 UTC, Guenther Deschner
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Lamboj 2010-03-22 07:35:34 UTC
cupsaddsmb -H server-p -v EDV01 EDV02 EDV03

Under Samba 3.2.14 this command works wihtout any Problem and i can set/change the Driver!
With Samba 3.5.1 i got this error: "cli_pipe_validate_current_pdu: RPC fault code DCERPC_FAULT_OP_RNG_ERROR" -> http://www.mail-archive.com/samba@lists.samba.org/msg100802.html. Both Samba Servers have the same Configuration and the same Log Level. The next and very critical Problem is that i can not add any printer Driver to the shared Printer! 

This Methods for uploading/setting the Driver wont work: 
 - cupsaddsmb
 - Windows XP Printer Dialog(Sometimes grey and i cannot select anything)
 - Manual upload of the Driver with smbclient and rpcclient

I got a "successfully installed." and "Successfully set EDV03 to driver EDV03."
But when i check which driver is used its only Empty and no Driver is used:

rpcclient server-p -c "getprinter EDV03 2" | grep driver
Enter root's password:
        drivername:[]

When i make an upgrade from 3.2.x to 3.5.x than the old Pritners are working, just the new one which i have added don't work and i cannot add a Driver to the Printer.

The Caption of the Windows XP Printer Dialog shows a "Access Denied, no connection possible"

Direct printing over CUPS works, wihtout Problems!

So god luck at bug hunting.
Comment 1 Richard Lamboj 2010-03-22 08:35:46 UTC
I have tried the same on a Samba 3.5.0 Member Server on x86 and it works without Problems! The Member Server uses Winbind to connect to the Samba PDC.

server-m-dfs:/# cupsaddsmb -U MITARBEITER+root -H server-m-dfs -v EDV01
Kennwort für MITARBEITER+root erforderlich, um über SAMBA auf server-m-dfs zugreifen zu können:
Befehl ausführen: smbclient //server-m-dfs/print$ -N -A /tmp/4ba76e2379af0 -c „mkdir W32X86;put /tmp/4ba76e1d076a8 W32X86/EDV01.ppd;put /usr/share/cups/drivers/ps5ui.dll W32X86/ps5ui.dll;put /usr/share/cups/drivers/pscript.hlp W32X86/pscript.hlp;put /usr/share/cups/drivers/pscript.ntf W32X86/pscript.ntf;put /usr/share/cups/drivers/pscript5.dll W32X86/pscript5.dll“
Domain=[MITARBEITER] OS=[Unix] Server=[Samba 3.5.0]
NT_STATUS_OBJECT_NAME_COLLISION making remote directory \W32X86
putting file /tmp/4ba76e1d076a8 as \W32X86/EDV01.ppd (4091,7 kb/s) (average 4091,8 kb/s)
putting file /usr/share/cups/drivers/ps5ui.dll as \W32X86/ps5ui.dll (3900,0 kb/s) (average 3919,7 kb/s)
putting file /usr/share/cups/drivers/pscript.hlp as \W32X86/pscript.hlp (4904,8 kb/s) (average 4031,6 kb/s)
putting file /usr/share/cups/drivers/pscript.ntf as \W32X86/pscript.ntf (14384,1 kb/s) (average 10457,3 kb/s)
putting file /usr/share/cups/drivers/pscript5.dll as \W32X86/pscript5.dll (10907,0 kb/s) (average 10578,9 kb/s)

Befehl ausführen: rpcclient server-m-dfs -N -A /tmp/4ba76e2379af0 -c „adddriver "Windows NT x86" "EDV01:pscript5.dll:EDV01.ppd:ps5ui.dll:pscript.hlp:NULL:RAW:pscript5.dll,EDV01.ppd,ps5ui.dll,pscript.hlp,pscript.ntf"“
Connecting to host=server-m-dfs
Connecting to 127.0.0.1 at port 445
Doing spnego session setup (blob length=58)
got OID=1.3.6.1.4.1.311.2.2.10
got principal=NONE
Got challenge flags:
Got NTLMSSP neg_flags=0x60898215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60088215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60088215
Printer Driver EDV01 successfully installed.

Befehl ausführen: rpcclient server-m-dfs -N -A /tmp/4ba76e2379af0 -c „setdriver EDV01 EDV01“
Connecting to host=server-m-dfs
Connecting to 127.0.0.1 at port 445
Doing spnego session setup (blob length=58)
got OID=1.3.6.1.4.1.311.2.2.10
got principal=NONE
Got challenge flags:
Got NTLMSSP neg_flags=0x60898215
NTLMSSP: Set final flags:
Got NTLMSSP neg_flags=0x60088215
NTLMSSP Sign/Seal - Initialising with flags:
Got NTLMSSP neg_flags=0x60088215
Successfully set EDV01 to driver EDV01.

server-m-dfs:/# rpcclient server-m-dfs -U root -c "getprinter EDV01 2" | grep driver
Enter root's password:
        drivername:[EDV01]

So the Samba PDC is 64 bit and the Member Server is 32 bit. Both are running in a Linux Vserver, but only on the Member Server(32 bit) Samba Printing works.

Kind Regards,

Richi
Comment 2 Guenther Deschner 2010-05-03 09:35:20 UTC
Created attachment 5679 [details]
patch for 3.5
Comment 3 Guenther Deschner 2010-05-03 09:36:20 UTC
Created attachment 5680 [details]
patch for 3.4
Comment 4 Guenther Deschner 2010-05-03 09:49:54 UTC
Danke, Metze. Reassigning to Karolin.
Comment 5 Karolin Seeger 2010-05-04 02:29:48 UTC
Pushed to v3-5-test and v3-4-test.
Will be included in Samba 3.4.8 and 3.5.3.

Closing out bug report.

Thanks!
Comment 6 Karolin Seeger 2010-05-04 03:04:55 UTC
The 3.4 patch does not seem to compile on my box.
Comment 7 Guenther Deschner 2010-05-04 03:54:11 UTC
Created attachment 5681 [details]
followup patch for 3.4
Comment 8 Karolin Seeger 2010-05-04 04:25:27 UTC
(In reply to comment #7)
> Created an attachment (id=5681) [details]
> followup patch for 3.4
> 

Yes, this one fixes the build for me, thanks.
Reassigning to Metze for review.
Comment 9 Karolin Seeger 2010-05-04 04:42:49 UTC
Pushed to v3-4-test.
Closing out bug report.

Thanks!
Comment 10 Guenther Deschner 2010-05-10 07:20:20 UTC
*** Bug 7363 has been marked as a duplicate of this bug. ***
Comment 11 Guenther Deschner 2010-08-24 03:14:24 UTC
*** Bug 7643 has been marked as a duplicate of this bug. ***