Bug 7204 - net ads join createcomputer=Servers/Unix fails with out of memory
net ads join createcomputer=Servers/Unix fails with out of memory
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: Domain Control
3.5.0
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 7276 7306 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-03 06:57 UTC by Guenther Deschner
Modified: 2010-05-27 05:23 UTC (History)
2 users (show)

See Also:


Attachments
v3-5-test patch (2.27 KB, patch)
2010-03-03 07:00 UTC, Guenther Deschner
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2010-03-03 06:57:37 UTC
net ads join -U administrator -S w2k3 -d 10 createcomputer=Servers/Unix
...
Failed to join domain: failed to precreate account in ou (null): Out of memory
return code = -1

only joining to full qualified DNs is possible, like:

net ads join -U administrator -S w2k3 -d 10 createcomputer=ou=unix,OU=servers,DC=w2k3dom,DC=ber,DC=redhat,DC=com
Comment 1 Guenther Deschner 2010-03-03 07:00:05 UTC
Created attachment 5447 [details]
v3-5-test patch
Comment 2 Guenther Deschner 2010-03-03 07:00:36 UTC
Comment on attachment 5447 [details]
v3-5-test patch

Tested simos patch, works again now.
Comment 3 Guenther Deschner 2010-03-03 07:01:01 UTC
Karolin, please pick for 3.5.1
Comment 4 Karolin Seeger 2010-03-03 07:37:52 UTC
Pushed to v3-5-test.
Closing out bug report.

Thanks!
Comment 5 Guenther Deschner 2010-03-22 08:00:15 UTC
*** Bug 7276 has been marked as a duplicate of this bug. ***
Comment 6 Guenther Deschner 2010-05-27 05:23:45 UTC
*** Bug 7306 has been marked as a duplicate of this bug. ***