Bug 7122 - Reading a large browselist fails (server returns invalid values in subsequent SMBtrans replies)
Reading a large browselist fails (server returns invalid values in subsequent...
Status: RESOLVED DUPLICATE of bug 7119
Product: Samba 3.5
Classification: Unclassified
Component: File services
3.5.0pre2
All All
: P3 major
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-09 17:11 UTC by Jeremy Allison
Modified: 2012-05-25 19:41 UTC (History)
0 users

See Also:


Attachments
gzip'ed browse.dat used to reproduce the problem. (39.05 KB, application/octet-stream)
2010-02-09 17:13 UTC, Jeremy Allison
no flags Details
git am format patch for 3.5.0. (2.30 KB, patch)
2010-02-09 17:17 UTC, Jeremy Allison
metze: review+
Details
git-am format patch for 3.4.6. (1.97 KB, patch)
2010-02-09 17:21 UTC, Jeremy Allison
metze: review+
Details
git-am format patch for 3.3.11. (1.99 KB, patch)
2010-02-09 17:25 UTC, Jeremy Allison
metze: review+
Details
git-am format patch for 3.2.x. (1.97 KB, patch)
2010-02-09 17:45 UTC, Jeremy Allison
jra: review? (metze)
Details
git-am patch. Applies to 3.5.0 and 3.4.6. (885 bytes, patch)
2010-02-09 17:51 UTC, Jeremy Allison
metze: review+
Details
git-am patch applies to 3.3.11 and 3.2.x (880 bytes, patch)
2010-02-09 17:55 UTC, Jeremy Allison
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2010-02-09 17:11:42 UTC
Using the browse.dat file I will attach to this bug report, with the workgroup changed to the current one in smb.conf, 3.5.0rc2 returns a bad browselist to smbclient.

To reproduce, set up the browse.dat as explained, then do:

smbclient -L 127.0.0.1 -U% -p139

The returned list has missing elements.

There are two problems:

1). The server is off-by-one in the end of buffer space test.
2). The server returns 0 in the totaldata (smb_vwv1) and totalparams (smb_vwv0) fields in the second and subsequent SMBtrans replies.

This occurred in the recent SMBtrans rewrite and also affects 3.4.x. and 3.3.x.

Jeremy.
Comment 1 Jeremy Allison 2010-02-09 17:13:43 UTC
Created attachment 5304 [details]
gzip'ed browse.dat used to reproduce the problem.
Comment 2 Jeremy Allison 2010-02-09 17:14:43 UTC
Hmmm - goes all the way back to 3.2.x it seems !
Comment 3 Jeremy Allison 2010-02-09 17:17:49 UTC
Created attachment 5305 [details]
git am format patch for 3.5.0.
Comment 4 Jeremy Allison 2010-02-09 17:21:19 UTC
Created attachment 5306 [details]
git-am format patch for 3.4.6.
Comment 5 Jeremy Allison 2010-02-09 17:25:08 UTC
Created attachment 5307 [details]
git-am format patch for 3.3.11.
Comment 6 Jeremy Allison 2010-02-09 17:45:31 UTC
Created attachment 5308 [details]
git-am format patch for 3.2.x.
Comment 7 Jeremy Allison 2010-02-09 17:47:18 UTC
Volker, Metze, if you agree with the review I'll re-assign to Karolin for inclusion.

Jeremy.
Comment 8 Jeremy Allison 2010-02-09 17:51:49 UTC
Created attachment 5309 [details]
git-am patch. Applies to 3.5.0 and 3.4.6.

Missed this one - it's also needed. Fixes a valgrind error in libsmb/clirap.c when reading a fully returned browselist.

Jeremy.
Comment 9 Jeremy Allison 2010-02-09 17:55:00 UTC
Created attachment 5310 [details]
git-am patch applies to 3.3.11 and 3.2.x

Second part of the patch. Also needed.
Comment 10 Stefan Metzmacher 2010-02-10 03:17:31 UTC
Comment on attachment 5305 [details]
git am format patch for 3.5.0.

Karolin please pick this one for 3.5.0
Comment 11 Stefan Metzmacher 2010-02-10 03:17:43 UTC
Comment on attachment 5309 [details]
git-am patch. Applies to 3.5.0 and 3.4.6.

Karolin please pick this one for 3.5.0
Comment 12 Stefan Metzmacher 2010-02-10 03:24:39 UTC
Comment on attachment 5306 [details]
git-am format patch for 3.4.6.

Looks good for 3.4.6
Comment 13 Stefan Metzmacher 2010-02-10 03:25:03 UTC
Comment on attachment 5309 [details]
git-am patch. Applies to 3.5.0 and 3.4.6.

also good for 3.4.6
Comment 14 Stefan Metzmacher 2010-02-10 03:28:53 UTC
Comment on attachment 5307 [details]
git-am format patch for 3.3.11.

Looks good for 3.3.11
Comment 15 Stefan Metzmacher 2010-02-10 03:29:20 UTC
Comment on attachment 5310 [details]
git-am patch applies to 3.3.11 and 3.2.x

Looks good for 3.3.11
Comment 16 Karolin Seeger 2010-02-10 03:37:20 UTC
(In reply to comment #10)
> (From update of attachment 5305 [details])
> Karolin please pick this one for 3.5.0
> 

Pushed.
Comment 17 Karolin Seeger 2010-02-10 03:37:43 UTC
(In reply to comment #11)
> (From update of attachment 5309 [details])
> Karolin please pick this one for 3.5.0
> 

Pushed.
Comment 18 Karolin Seeger 2010-02-11 04:34:30 UTC

*** This bug has been marked as a duplicate of bug 7119 ***