Bug 7119 - support for large browselist
support for large browselist
Status: RESOLVED FIXED
Product: Samba 3.5
Classification: Unclassified
Component: File services
3.5.0rc2
Other Linux
: P3 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 7122 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-08 12:22 UTC by Stefan Metzmacher
Modified: 2010-02-22 09:17 UTC (History)
1 user (show)

See Also:


Attachments
Patch for v3-5 (16.47 KB, patch)
2010-02-08 12:23 UTC, Stefan Metzmacher
jra: review+
Details
Additional Patch for v3-5 (2.69 KB, patch)
2010-02-09 12:27 UTC, Stefan Metzmacher
jra: review+
Details
Backports to v3-4 (includes patches from bug 7122) (22.38 KB, patch)
2010-02-10 11:44 UTC, Stefan Metzmacher
jra: review+
Details
Backports to v3-3 (includes patches from bug 7122) (only the minum changes) (5.97 KB, patch)
2010-02-10 13:31 UTC, Stefan Metzmacher
jra: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2010-02-08 12:22:36 UTC
Fix/implement support for large browselist (NetServerEnum3)
Comment 1 Stefan Metzmacher 2010-02-08 12:23:47 UTC
Created attachment 5298 [details]
Patch for v3-5
Comment 2 Jeremy Allison 2010-02-08 17:15:59 UTC
Comment on attachment 5298 [details]
Patch for v3-5

Patchset looks good to me. Not sure whether is is a 3.5.0, or a 3.5.1 patch....

I'll leave this up to Karolin to decide :-).

Jeremy.
Comment 3 Jeremy Allison 2010-02-08 17:16:27 UTC
Re-assigning to Karolin for consideration for 3.5.0, or 3.5.1.

Jeremy.
Comment 4 Karolin Seeger 2010-02-09 03:45:26 UTC
Pushed to v3-5-test. Will be included in 3.5.0.
Closing out bug report.

Thanks!
Comment 5 Jeremy Allison 2010-02-09 12:19:30 UTC
Karolin, we also need to pull in git refs 1686a5e7e7eb1b411b003cbbde5c0d28741c6d02 and bc8242a08e1bb9489cc8171b1ec02bd2518b1857 from mater to fully fix this bug.

Sorry I missed these in my review.

Jeremy.
Comment 6 Stefan Metzmacher 2010-02-09 12:27:05 UTC
Created attachment 5302 [details]
Additional Patch for v3-5
Comment 7 Stefan Metzmacher 2010-02-10 11:44:17 UTC
Created attachment 5320 [details]
Backports to v3-4 (includes patches from bug 7122)
Comment 8 Jeremy Allison 2010-02-10 12:17:24 UTC
Comment on attachment 5302 [details]
Additional Patch for v3-5

Yes, definitely needed - thanks !
Comment 9 Jeremy Allison 2010-02-10 12:40:43 UTC
Comment on attachment 5320 [details]
Backports to v3-4 (includes patches from bug 7122)

Hmmm. Ok, I'm good with this (I wasn't originally planning to add the NetServerEnum3 code to 3.4.6, but if you've tested and are ok with it, I'm happy. It's the same code that's in 3.5.0 anyway).
Comment 10 Stefan Metzmacher 2010-02-10 13:31:03 UTC
Created attachment 5321 [details]
Backports to v3-3 (includes patches from bug 7122) (only the minum changes)
Comment 11 Karolin Seeger 2010-02-11 04:17:59 UTC
(In reply to comment #5)
> Karolin, we also need to pull in git refs
> 1686a5e7e7eb1b411b003cbbde5c0d28741c6d02 and
> bc8242a08e1bb9489cc8171b1ec02bd2518b1857 from mater to fully fix this bug.
> 
> Sorry I missed these in my review.
> 
> Jeremy.

Pushed.

Comment 12 Karolin Seeger 2010-02-11 04:30:03 UTC
(In reply to comment #7)
> Created an attachment (id=5320) [details]
> Backports to v3-4 (includes patches from bug 7122)
> 

Pushed to v3-4-test.
Comment 13 Karolin Seeger 2010-02-11 04:33:17 UTC
(In reply to comment #10)
> Created an attachment (id=5321) [details]
> Backports to v3-3 (includes patches from bug 7122) (only the minum changes)
> 

This is the only one still missing (waiting for review).
Comment 14 Karolin Seeger 2010-02-11 04:34:30 UTC
*** Bug 7122 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Allison 2010-02-11 10:44:02 UTC
Comment on attachment 5321 [details]
Backports to v3-3 (includes patches from bug 7122) (only the minum changes)

Looks ok to me.
Comment 16 Stefan Metzmacher 2010-02-22 09:09:17 UTC
Karolin please pull into v3-3-test
Comment 17 Karolin Seeger 2010-02-22 09:17:49 UTC
Pushed to v3-3-test.
Closing out bug report.

Thanks!