Bug 6985 - dirsort plugin provides only the first 155 entries
dirsort plugin provides only the first 155 entries
Status: RESOLVED DUPLICATE of bug 8721
Product: Samba 3.3
Classification: Unclassified
Component: VFS Modules
3.3.9
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 08:11 UTC by Philippe Michel
Modified: 2014-10-30 11:26 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Michel 2009-12-10 08:11:11 UTC
If a share uses the dirsort plugin, the client gets only the first 155 entries of directories (by default ?).

It depends on the client application : a "dir" in a cmd gets the whole list immediately , Windows explorer gets 155 but a refresh gives the whole list, and some application I use has a dumb file chooser that doesn't sort what it receives, gets only 155 entries from dirsort and has no refresh function...

I tried to tweak the "directory name cache size" parameter but it didn't help.
Comment 1 Nestor III 2010-07-06 16:40:59 UTC
(In reply to comment #0)
> If a share uses the dirsort plugin, the client gets only the first 155 entries
> of directories (by default ?).
> 
> It depends on the client application : a "dir" in a cmd gets the whole list
> immediately , Windows explorer gets 155 but a refresh gives the whole list, and
> some application I use has a dumb file chooser that doesn't sort what it
> receives, gets only 155 entries from dirsort and has no refresh function...
> 
> I tried to tweak the "directory name cache size" parameter but it didn't help.
> 

Guys, i don't know if it's the same problem, but i (almost) lost data because of dirsort. When copying from share with "dirsort" enabled, it copies only part of the files and folders if the quantity is really large. Don't know if it's  155, but the problem is really there! Ditching the really useful "dirsoft" module for now :(
P.S. Backups are lifesavers!


uname -a
Linux Beast 2.6.32-5-amd64 #1 SMP Tue Jun 1 04:34:03 UTC 2010 x86_64 GNU/Linux

smbd -V
Version 3.4.8

cat /etc/samba/smb.conf 
[global]
netbios name = Beast
workgroup = WORKGROUP
server string =
dns proxy = no
interfaces = lo eth2
bind interfaces only = yes
log file = /var/log/samba/log.%m
max log size = 1000
keep alive = 120
dead time = 0
syslog = 0
log level = 0
read raw = yes
write raw = yes
panic action = /usr/share/samba/panic-action %d
getwd cache = yes
domain master = Yes
local master = Yes
preferred master = Yes
os level = 35
wins support = yes
name resolve order = wins hosts lmhosts bcast
security = user
pencrypt passwords = true
passdb backend = tdbsam
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE
printing = cups
printcap name = cups

[d]
path = /media/d/
browseable = yes
writeable = yes
create mask = 0666
directory mask = 0777
hide files = /~*/*.part/Thumbs.db/*.hidden/desktop.ini/
veto files = /.*/lost+found/
delete veto files = true
oplocks = yes
nt acl support = no
vfs object = recycle dirsort
#vfs object = recycle
recycle:repository = Home/Trash
recycle:keeptree = Yes
recycle:touch = Yes
recycle:versions = Yes
recycle:maxsixe = 0

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable printer drivers
[print$]
   comment = Printer Drivers
   browseable = no
   path = /root/install/printer/drivers
   read only = yes
   guest ok = no
   write list = root
Comment 2 Bug Reporter 2014-10-30 05:13:46 UTC
Just wanted to point out that this is STILL an issue years and years later, and it's one that can absolutely result in data loss. If no one is going to contribute a fix, this plugin should be removed from the distribution completely. As is, it's a disaster waiting to happen to anyone who touches it.
Comment 3 Björn Jacke 2014-10-30 11:26:30 UTC

*** This bug has been marked as a duplicate of bug 8721 ***