Bug 6882 - Do not work VFS full_audit
Do not work VFS full_audit
Status: RESOLVED DUPLICATE of bug 6557
Product: Samba 3.4
Classification: Unclassified
Component: VFS Modules
3.4.3
x86 Solaris
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 20:54 UTC by Kazunori Kojima
Modified: 2010-02-15 16:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kazunori Kojima 2009-11-09 20:54:14 UTC
Can not open Word 2003 and Excel 2003 file when load full_audit module.

1. Settings 

smb.conf:
    [global]
        dos charset = CP932
        display charset = CP932
        server string = SAMBA
        map to guest = Never
        log level = 0
        log file = /var/log/samba/smbd.log
        hosts allow = 10.0.0.0/24, 127.0.0.0/8
        hosts deny = ALL
        vfs objects = full_audit
        force directory mode = 0774
        force create mode = 0774
    #   oplocks = No
    
    [share]
        path = /var/share/
        valid users = +users
        force group = users
        read only = No
        create mask = 0774

2. Operation

- Open "test.xls" with Excel 2003

3. Additional Information

I try vfstest command:

(without full_audit)
    $ ./bin/vfstest
    vfstest $> mkdir /tmp/b
    vfs_extd_audit: mkdir /tmp/b
    mkdir: ok
    vfstest $> disk_free .
    disk_free: 1645806, bsize = 512, dfree = 3291612, dsize = 10331676
    vfstest $> chdir ..
    chdir: ok
    vfstest $>

(with full_audit)
    $ ./bin/vfstest
    vfstest $> load full_audit
    load: ok
    vfstest $> mkdir /tmp/b
    log_success() failed to get vfs_handle->data!
    Segmentation Fault (core dumped)
    $ ./bin/vfstest
    vfstest $> disk_free .
    log_success() failed to get vfs_handle->data!
    Segmentation Fault (core dumped)
    $ ./bin/vfstest
    vfstest $> chdir ..
    log_success() failed to get vfs_handle->data!
    Segmentation Fault (core dumped)

I tried samba-3.4.0 and samba-3.4.3 with Solaris8, Solaris9 and linux-2.6.29, all the same result.
Comment 1 Holger Hetterich 2010-02-15 16:04:43 UTC

*** This bug has been marked as a duplicate of bug 6557 ***