Bug 6727 - Printer issues on 3.4.x and 3.5.x
Printer issues on 3.4.x and 3.5.x
Status: RESOLVED WORKSFORME
Product: Samba 3.5
Classification: Unclassified
Component: Printing
3.5.6
x86 Windows XP
: P3 critical
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-15 02:45 UTC by Marc Muehlfeld
Modified: 2011-04-20 15:27 UTC (History)
3 users (show)

See Also:


Attachments
Level 10 log from clicking to properties until I comes up (256.00 KB, application/octet-stream)
2009-09-15 02:45 UTC, Marc Muehlfeld
no flags Details
ntprinters.zip (90.69 KB, application/x-zip-compressed)
2010-03-01 04:30 UTC, Marc Muehlfeld
no flags Details
patch for 3.5 (114.54 KB, patch)
2010-03-09 05:53 UTC, Guenther Deschner
metze: review+
Details
patch for 3.4 (81.77 KB, patch)
2010-03-09 07:37 UTC, Guenther Deschner
metze: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2009-09-15 02:45:06 UTC
I set up samba to provide the driver and some preconfigured settings to the workstations.

After upgrading from 3.3.7 to 3.4.1, if I right-click to one of my printers and choose "Properties", it takes several minutes until the window comes up. And also when I click to the "standard values" button on "Extended", it takes about 20 seconds until the next window appears.

Also if I change the configuration (e. g. configure 4 cartridges instead of 2), it is not be saved).
Comment 1 Marc Muehlfeld 2009-09-15 02:45:40 UTC
Created attachment 4694 [details]
Level 10 log from clicking to properties until I comes up
Comment 2 Guenther Deschner 2009-09-23 06:53:01 UTC
Are you saying it worked all fine with 3.3.7 and broke with 3.4.x ?
Comment 3 Marc Muehlfeld 2009-09-23 06:56:28 UTC
Haven't tried that on 3.4.0. But yes, it was fine on 3.3.7 and I first time saw this on this on 3.4.1.

Now I currently switched back to 3.3.7 on my productive environment.
Comment 4 Karolin Seeger 2009-10-14 04:41:53 UTC
Is this one a show stopper for 3.4.3?
Comment 5 Jeremy Allison 2009-10-19 15:51:29 UTC
Reducing this to "critical" from blocker. It's a specific printer which doesn't mean all printers are broken. Guenther can you review the bug please to confirm if my analysis is correct ?
Jeremy.
Comment 6 Günter Gersdorf 2009-11-11 09:26:45 UTC
(In reply to comment #5)
> Reducing this to "critical" from blocker. It's a specific printer which doesn't
> mean all printers are broken. Guenther can you review the bug please to confirm
> if my analysis is correct ?
> Jeremy.
> 
It seems, that all printers are broken. Its possible to set 'Duplex Unit: installed' in the device settings and to select 'Print on both sides' in the printer preferences for the printers in the network neighborhood. But when a user actually uses the printer, there are no GUI elements in the print preferences to use the duplex unit.
Comment 7 Guenther Deschner 2010-01-13 07:52:25 UTC
Marc, it should be resolved (at least work like 3.3.x releases again), can you please check with 3.4.4 ?
Comment 8 Marc Muehlfeld 2010-01-17 07:55:30 UTC
Problem exists unchanged in 3.4.4.

Opening the properties of a printer still took about 1:30 mins and all settings were reseted (e. g. number of catridges). I set debug level to 10 and opened the properties. Until the window came up, I got about 2 GB log!
Comment 9 Marc Muehlfeld 2010-02-17 14:52:37 UTC
Problem also exist unchanged in 3.4.5.

Is there anything I can do to help fixing this issue? Here it is a showstopper for switching to 3.4 or later.

Please let me know if I can do anything to help you fixing this issue.
Comment 10 Guenther Deschner 2010-02-26 11:15:00 UTC
Marc, sorry to ask, can you check again with 3.4.6 ?
Comment 11 Marc Muehlfeld 2010-02-26 11:34:39 UTC
Same with 3.4.6.


Any more help I can give? We would really like to switch to 3.4 (because of the samba4 feature we require). But this and one other bug are showstoppers for 3.4 at the moment here.
Comment 12 Guenther Deschner 2010-02-26 11:46:38 UTC
ok, just the usual things: 

* tell what exactly printer that is (hopefully not the HP LaserJet 4250 PCL5 as that is really still problematic)
* log level = 10 (try to really isolate the traffic from that one testing host, via "log file = /var/log/samba/log.%m")
* what exact client version

we will really nail it down this time.
Comment 13 Marc Muehlfeld 2010-02-26 12:08:30 UTC
I think I have this problem with all of our printers. E. g. Sharp MX 2600n (PS), HP Laserjet 4250 (Universal Printer Driver),...

The compressed level 10 log was 72 kb to large for attaching it. So please download it here: http://www.medizinische-genetik.de/amplicon.log.tar.bz2
It contains:
Right-click to printer SHMX2600-6_SW, click to "Configuration" to verify that all cadridges are there (they were this time), click to "Extended", click to "default values", click to "extended" and turned on "PS Error Information", click to "OK". Then I got an error message.

I tried this twice (during that I reset the databases to the copies from my 3.3.9 version). The second time the error doesn't come up, but all settings are reset to default (2 cadriges instead of 4,...) and none of my changes was saved.

Please just let me know if there is more I can do to help you.
Comment 14 Guenther Deschner 2010-02-26 12:36:34 UTC
(In reply to comment #13)
> Please just let me know if there is more I can do to help you.

Thanks for the log!

wow, I finally see what is failing, its a rather large SPOOLSS_ENUMPRINTERDATAEX reply that fails to marshall.

Could you generate a network trace of that same action you did for generating the log?
Comment 15 Marc Muehlfeld 2010-02-28 10:59:49 UTC
I created a network trace with the same steps.

I saw, that sometimes, I also get "Printer properties could not be displayed" (I don't know the exact wording in english), when I open the properties of a printer.

Is it a problem that is related to our setup/environment here or is it a general issue?

Please just let me know if you need more logs, etc.
Comment 16 Marc Muehlfeld 2010-02-28 11:09:09 UTC
Ups. Sorry. I forgot the download link (was to big to attach here).

http://www.medizinische-genetik.de/network.trace.tar.bz2
Comment 17 Guenther Deschner 2010-03-01 04:23:50 UTC
Thanks, could you also please upload your /var/lib/samba/ntprinters.tdb file ?

It is quite hard to reproduce here, as the Sharp MX 2600n driver wont install w/o having such a neat box...
Comment 18 Marc Muehlfeld 2010-03-01 04:30:55 UTC
Created attachment 5433 [details]
ntprinters.zip

See attached the zipped ntprinters.tdb.

Samba delivers the driver here to the workstations. And I'm sure, I uploaded the drivers to the server, before we got the devices.

You can upload them and then add a printer to smb.conf and lpd (we use lpd here, not cups). Then you can configure the printer without having the device.

I think the problem is appearing on other printer drivers, too. But most of the printers we use are the big Sharp MX2600, so I only checked this.
Comment 19 Guenther Deschner 2010-03-04 04:15:14 UTC
Ok, Marc. We do know exactly what we are still doing wrong now, thanks to your debugging info. I am actively working/test a patch for 3.4.x and 3.5.x. 
Comment 20 Marc Muehlfeld 2010-03-04 04:18:20 UTC
Great.

If you have a patch I can test, just let me know. I think, we would directly switch to 3.5 if it's fixed.
Comment 21 Guenther Deschner 2010-03-09 05:53:03 UTC
Created attachment 5473 [details]
patch for 3.5

3.4 patch to follow soon
Comment 22 Stefan Metzmacher 2010-03-09 06:17:22 UTC
Comment on attachment 5473 [details]
patch for 3.5

Looks good for 3.5.2
Comment 23 Guenther Deschner 2010-03-09 07:37:39 UTC
Created attachment 5475 [details]
patch for 3.4
Comment 24 Stefan Metzmacher 2010-03-09 07:45:15 UTC
Comment on attachment 5475 [details]
patch for 3.4

Looks good
Comment 25 Guenther Deschner 2010-03-09 07:47:36 UTC
Karolin, please pick for 3.5.2 and 3.4.8
Comment 26 Guenther Deschner 2010-03-09 08:20:25 UTC
Marc, if you could test the patches that would be nice of course (they should cleanly apply on 3.4.6 and 3.5.1).

I ran samba with your ntprinters.tdb and spoolss_EnumPrinterDataEx was nicely returning the data the windows client has stored.
Comment 27 Marc Muehlfeld 2010-03-09 08:33:48 UTC
I will try it tonight and update this bugreport.
Comment 28 Marc Muehlfeld 2010-03-09 12:25:15 UTC
Patch works on 3.4.6 and 3.5.1. Thanks.


But is it normal that opening the properties takes mostly 20-120 seconds (on 3.3 to 3.5) until the window appears? And in the meantime there is a smbd process taking about 70% CPU here. If it's not normal, I can open a new bugreport and add logs/traces.
Comment 29 Guenther Deschner 2010-03-09 13:51:40 UTC
(In reply to comment #28)
> Patch works on 3.4.6 and 3.5.1. Thanks.

Great! so we have at least that resolved.

> But is it normal that opening the properties takes mostly 20-120 seconds (on
> 3.3 to 3.5) until the window appears? And in the meantime there is a smbd
> process taking about 70% CPU here. If it's not normal, I can open a new
> bugreport and add logs/traces.

Are you saying that (assuming not running under debug level = 10) things were considerably faster with 3.0.x ?
Comment 30 Marc Muehlfeld 2010-03-10 00:42:20 UTC
That we used 3.0.x is some time ago, so I can't compare it very good. But I guess it is slower since using 3.2 or 3.3.

It seems that opening the properties sometimes is fast (<10 sec.). But often it takes 20-120 sec. to open. I allready deleted all samba tdb files and reinstalled samba, printer drivers, etc. from scratch, without changes.

Maybe it has something to do with one other open printer problem (Bug #6632) we have.
Comment 31 Marc Muehlfeld 2010-03-10 15:59:13 UTC
Maybe something isn't totally fixed with your patch. The properties on the server are fine now. But e. g. on my workstation one of my two mapped printers lost one of it's settings (the default cartridges).
Comment 32 Karolin Seeger 2010-03-11 03:33:30 UTC
Pushed patches to v3-5-test and v3-4-test.

Re-assigning to Günther for further investigations.

Thanks!
Comment 33 Marc Muehlfeld 2010-03-11 05:42:45 UTC
I reinstalled the printer with the missing settings and then it got it's default cartridges from the server again. Everything was fine. But 10 h and one logon later the setting is again gone. So I'll switch back to 3.3.11 tonight again.
Comment 34 Marc Muehlfeld 2010-03-12 15:34:29 UTC
I did some tryings and the problem is reproducable:

I switched back to 3.3.11, removed the printer on the workstation and added it again:

Client settings: Default cartridge is LCT
Server settings: Default cartridge is LCT

I upgraded samba to 3.5.1 (with your patch):

Client settings: Default cartridge is LCT
Server settings: Default cartridge is LCT

After some minutes:

Client settings: Default cartridge is Automatic
Server settings: Default cartridge is LCT


With "server settings" I mean the settings of the printer driver I configure on the server an that got delivered to the workstations/users when they add the printer.
Comment 35 Guenther Deschner 2010-03-12 17:34:17 UTC
Thanks for checking again. This happends with the Sharp MX 2600n driver and the settings stored as in your ntprinters.tdb, right ?
Comment 36 Marc Muehlfeld 2010-03-14 10:42:35 UTC
> This happends with the Sharp MX 2600n driver and the
> settings stored as in your ntprinters.tdb, right ?

Yes. But I haven't checked the other printers.


The interesting is, that it seems not be be on all Sharp printers.
I have on physical printer with two logical in samba (e. g. SHMX2600-6_F and SHMX2600-6_SW) with different settings (one is default black/white and the other is default color). The SHMX2600-6_SW doesn't seem to change by itself. The driver and all settings are completely the same on F and SW, except that one is default black/white and other color.
Comment 37 Marc Muehlfeld 2010-03-23 04:25:37 UTC
Can I give you some more debugs or other help to fix the remaining issue with lost printer settings?
Comment 38 Marc Muehlfeld 2010-05-05 05:25:30 UTC
I added "3.5.x" to the summary, because the problem is not fully fixed and it's still there in 3.5.2.

It would be great if we can fully fix this issue soon to allow upgrading to the latest version. Currently we have to stay at 3.3.x because of the bug.

If you need any logs, etc. pls let me know. I'll add them asap.
Comment 39 Marc Muehlfeld 2010-05-05 15:29:15 UTC
Just to give the latest status about the remaining issues (in 3.5.2):

- Opening printersettings on the server is terrible slow (60-240 seconds before the window comes up). Switching back to 3.3.12 and the window comes up in 5 seconds.

- After some time the printer default settings (e. g. cartridge) are reset to "automatic", even if the settings on the server are different. Re-saving the settings on the server doesn't push the setting to the client any more. Also reinstalling the printer on the client doesn't load the correct settings from the server. Switching back to 3.3.12 and the clients get automatically a few seconds later the correct settings back (same as on the server).
Comment 40 Marc Muehlfeld 2010-05-20 12:58:10 UTC
Problem still exist in 3.4.8 and 3.5.3.

I also find one more printer issue. I don't know, if its related to this one and created a new bug report #7445
Comment 41 Marc Muehlfeld 2010-07-26 05:29:02 UTC
Problem also still exist in 3.5.4.

Could you complete the half fixed bug, please? It would allow us to leave 3.3 and move to the latest version.
Comment 42 Greg Auz 2010-10-21 05:24:15 UTC
Hello All,

I can confirm the bug pointed by Marc.
We migrate some days ago a server to Debian Squeeze with samba 3.5.5 and cups 1.4.4 and suffer the same problem.
- A huge time displaying parameters (10-20secs, comparing to samba 3.0.24 with less than a second)
- A dalay before starting to print (maybe involved by the previous problem, windows need to look parameters each time a print is occured)



Thank you all for the good work with samba, keep up with it ! :)


Comment 43 Chris Meyer 2010-10-28 15:16:56 UTC
Confirming bug of device settings not pushed to normal domain users in 3.4.9. This problem has been in every 3.4.x we have tried.
Comment 44 Marc Muehlfeld 2010-10-29 01:07:57 UTC
Problem came up in 3.4.0 and hasn't been fixed until the latest version yet (last checked version was 3.5.6).
Comment 45 Marc Muehlfeld 2011-01-17 08:43:01 UTC
Guenther, maybe you can help finally fixing this issue.

I meanwhile figured out, that this bug doesn't exist for users having the
privilege "SePrintOperatorPrivilege".

If I grant SePrintOperatorPrivilege for a normal user, where the settings are
shown wrong, everything is fine after re-login. If I revoke the privilege and
re-login again, it's broken like before.
Comment 46 Robert Sander 2011-02-07 16:31:49 UTC
Hi,

I just wanted to add that we are experiencing the same issue.

I had to add @users (all our users) to the "printer admin" parameter of the [printers] section in smb.conf.

Setting the privilege SePrintOperatorPrivilege did not work as described here.

This is on a Samba 3.5.6 on Debian squeeze. This Samba instance is a domain member server of a Samba 3.5.6 PDC.
Comment 47 Marc Muehlfeld 2011-02-08 01:25:23 UTC
Hello Robert Sander,

with what kind of drivers you experienced this problem?
Comment 48 Robert Sander 2011-02-08 17:10:25 UTC
(In reply to comment #47)

> with what kind of drivers you experienced this problem?

We have mostly the HP Universal Driver in use, but also some Sharp printers.

It looks like this is not related to the Windows printer driver.
Comment 49 Marc Muehlfeld 2011-02-09 02:04:36 UTC
I already searched the web and found some mailinglist entries and some other comments about more users having the same issue.

I really hope Gunther or some other developer continues fixing this issue soon. I reported this in 2009. And at least when 3.3 support ends, there is a huge problem for all having this problem.
Comment 50 Daniel Houlbrooke 2011-02-10 17:45:47 UTC
Hi,

Just adding another "me too". I have experienced the same issues as described by Marc using a range of different printers/drivers.

It does not appear to be specific to printer driver - as I have had the issue with Kyocera/Konica Minolta/HP/Lexmark printers. The only thing I would note although is that all drivers/printers are postscript.

For the moment I have had to roll back to 3.3.14 to work around this issue.
Comment 51 Marc Muehlfeld 2011-02-14 03:59:17 UTC
Here the problem is not just with PS drivers. I have this with PCL and even with the PPD driver as well. (Sharp MX 2600).
Comment 52 Marc Muehlfeld 2011-03-08 09:53:17 UTC
After some tests, it seems, that 3.5.8 fixes this issue.

The changelog of that version doesn't list exactly this problem, but maybe it was fixed with the "printing issues on win7" bugs. I'll do some further testings and give a final result during the next days. But currently it looks good.
Comment 53 Marc Muehlfeld 2011-03-10 08:44:59 UTC
After having 3.5.8 now since 2 days in production, I can say, this version fixes the issue with our Sharp MX 2600n drivers, that was introduced in 3.4.0.
Comment 54 Robert Sander 2011-03-12 21:26:15 UTC
After a short test of 3.5.8 (compiled form Debian sid on Debian squeeze) I can confirm that the printer driver settings issues seems to be resolved.