Bug 6632 - Assigning driver to printer brings access violation
Assigning driver to printer brings access violation
Product: Samba 3.5
Classification: Unclassified
Component: Printing
x86 Windows XP
: P3 normal
: ---
Assigned To: Guenther Deschner
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2009-08-12 15:27 UTC by Marc Muehlfeld
Modified: 2011-04-28 12:18 UTC (History)
2 users (show)

See Also:

vm-02.log.gz (129.74 KB, application/x-gzip)
2009-08-12 15:31 UTC, Marc Muehlfeld
no flags Details
rpcclient_level_10_debug.txt (35.57 KB, text/plain)
2011-03-10 09:11 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2009-08-12 15:27:56 UTC
I upload printer drivers to my samba server. Then I open the properties of a new added printer, and assign the driver to it in the advanced tab. If I click to "OK" or "Apply", I get a

> Function address 0x2d04193 created an access violation (Code: 0xc0000005)

After closing the window, the driver is assigned in the list view and the advanced tab. But the settings of the driver aren't displayed.

I meanwhile removed all drivers from my server (removed everything out of print$), deleted all *.tdb and reinstalled the whole samba server. But without changes. Also it's reproduceable in my VM, where I set up a test environment for that meanwhile.

It's reproducable at least with the following drivers:
- HP LaserJet 2420 PCL6
- HP LaserJet 2420 PS
- HP LaserJet 4250 PCL6

The error is reproducable on (I only tried this versions):
- 3.0.34
- 3.3.4 to 3.3.7
- 3.4.0
Comment 1 Marc Muehlfeld 2009-08-12 15:31:42 UTC
Created attachment 4548 [details]

Compressed debug level 10 logfile of assigning one of the trouble making drivers to a new printer.
Comment 2 Marc Muehlfeld 2010-02-17 14:51:34 UTC
Is there anything I can do to help fixing this issue? Just let me know. It is a very big problem here, because many drivers can't be used. A full reinstallation of whole samba (incl. all databases, etc) doesn't fix the issue.

I tried it with 3.4.5 meanwhile. There the problem still exists.
Comment 3 Alessandro Bono 2010-03-22 06:06:41 UTC

similar problem here, if I try to assign a driver to printer I receive this error

Function address 0x5c1284f9 created an access violation (Code: 0xc0000005)

samba 3.4.7 + patch https://bugzilla.samba.org/attachment.cgi?id=5475 on a Ubuntu Hardy 64bit
driver for HP Laserjet P2055dn PCL6
client windows xp pro sp3 32bit

tell me if you need other info or test patch
Comment 4 Alessandro Bono 2010-04-16 06:24:49 UTC
Tested samba 3.5.2 with HP Color Laserjet 2600n but not working. The difference is that windows not crash but tell it's not possible to find specified driver.
There are new driver for HP Laserjet P2055dn and I'll try asap with samba 3.5.2

Any news or development patches to test??

Comment 5 Marc Muehlfeld 2010-04-16 06:32:40 UTC
I use for HP printers with problems the "HP Universal Printer Driver" as replacement. But this driver is really a pain (but at least you can print with it)

I hope somebody could fix this old problem, I'm having for a long time now.
Comment 6 Alessandro Bono 2010-05-24 08:34:10 UTC
Hi Guenther

I tested again with samba 3.5.3 to install driver for HP Laserjet P2055dn with a windows 2003 x64 and I receive again an access violation
Comment 7 Alessandro Bono 2010-06-24 10:47:37 UTC

this time tested with samba 3.5.4 and latest driver for hp laserjet p2055x (ver 6.1) with the same result
Comment 8 Marc Muehlfeld 2010-09-13 08:52:46 UTC
The problem comes with the newer HP printer drivers. If I use old version (around 2005), everything is fine and I don't get an access violation.

Because hp.com doesn't list old versions and the directories on their FTP aren't named like the printernames, you can use http://www.driverstock.com to find an old one. The download links point directly to the FTP from HP (so no misterious package to download from somewhere).

But all in all this is just a workaround, to use old driver version. It would be better, if it is fixed, because it seems to happen with various (HP only?) drivers.
Comment 9 Marc Muehlfeld 2011-03-10 09:10:32 UTC
Bug is still existing in 3.5.8.

Also assigning the driver via 'rpcclient' fails:

# rpcclient -U administrator -c 'setdriver HPLJ4250-3 "HP LaserJet 4250 PS"'

I attached a level 10 debug of the rpcclient command as well.
Comment 10 Marc Muehlfeld 2011-03-10 09:11:12 UTC
Created attachment 6283 [details]
Comment 11 Guenther Deschner 2011-04-20 14:20:11 UTC
Marc, can you please check if the patch from Bug #8038 fixes this issue ?
Comment 12 Marc Muehlfeld 2011-04-26 07:37:14 UTC
Sorry. I had no time last week to test. I will do during this week, when I got my test environment back working.
Comment 13 Marc Muehlfeld 2011-04-28 12:18:28 UTC
I applied the patch to the 3.5.8 sources and recompiled/installed samba. But it doesn't help. The access violation still comes up, when assigning the driver.