Bug 6698 - Windows 98 clients fail to complete login
Windows 98 clients fail to complete login
Status: RESOLVED DUPLICATE of bug 6551
Product: Samba 3.4
Classification: Unclassified
Component: Domain Control
3.4.0
x86 Windows 98
: P3 major
: ---
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 06:06 UTC by Lorenzo Marcantonio
Modified: 2009-09-08 06:11 UTC (History)
0 users

See Also:


Attachments
Level 10 log of a failed windows 98 login (50.16 KB, text/plain)
2009-09-08 06:10 UTC, Lorenzo Marcantonio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lorenzo Marcantonio 2009-09-08 06:06:10 UTC
Doesn't seem to be related to 6631.

2000 and XP client works ok. Samba 3.2 worked ok (before the upgrade).
After updating to 3.4 Windows 98 clients don't login anymore with a strange error message (something about a network resource name, it's italian localized I don't know its englis equivalent). The password seems to be recognized because with a wrong one it says so (quite correctly)

I'll supply smb.conf and a level 10 log to aid troubleshooting

The culprit seems to be in the lines

[2009/09/08 12:43:28,  4] smbd/reply.c:675(reply_tcon_and_X)
  Client requested device type [?????] for share [IPC$]
[2009/09/08 12:43:28,  1] smbd/service.c:1106(make_connection)
  make_connection: refusing to connect with no session setup

But I have no idea of what is wrong here...
Comment 1 Lorenzo Marcantonio 2009-09-08 06:08:25 UTC
smb.conf (removed lots of file sharing definitions):

[global]
        admin users = root
        algorithmic rid base = 1000
        allow trusted domains = yes
        bind interfaces only = yes
        blocking locks = yes
        case sensitive = no
        csc policy = disable
        default case = lower
        display charset = UTF8
        domain logons = yes
        domain master = yes
        enhanced browsing = yes
        guest account = nobody
        hostname lookups = yes
        interfaces = eth2 lo
        kernel change notify = yes
        lanman auth = yes
        level2 oplocks = no
        lm announce = no
        local master = yes
        log file = /var/log/samba/smb.%M.log
        log level = 1
        max log size = 10000
        logon drive = z:
        logon home = \\motoko\%U\w98profile
        logon path = \\motoko\profiles\%U
        logon script = nlogon.bat
        name resolve order = lmhosts host wins bcast
        netbios name = MOTOKO
        oplocks = no
        os level = 64
        check password script = /usr/sbin/crackcheck -d /usr/share/cracklib/pw_dict
        pam password change = yes
        passdb backend = tdbsam
        passdb expand explicit = no
        pid directory = /var/run
        preferred master = yes
        printing = lprng
        private dir = /etc/samba/private
        security = user
        server string = Samba %v - %h
        smb passwd file = /etc/samba/smbpasswd
        socket address = 192.168.0.222
        socket options = TCP_NODELAY
        syslog = 2
        syslog only = no
        time server = yes
        unix charset = UTF8
        unix extensions = yes
        unix password sync = yes
        username level = 0
        use client driver = no
        utmp = yes
        wins support = yes
        workgroup = LOGOSTEC

[homes]
        browseable = no
        guest ok = no
        read only = no

[printers]
        guest ok = no
        path = /var/spool/public
        printable = yes
        browseable = no

[print$]
        guest ok = no
        browseable = yes
        path = /data/print
        read only = no

[netlogon]
        browseable = yes
        guest ok = yes
        path = /data/netlogon
        read only = yes

[profiles]
        path = /data/profiles
        read only = no
        create mask = 0600
        directory mask = 0700
        browseable = no
        profile acls = yes
        csc policy = disable

Comment 2 Lorenzo Marcantonio 2009-09-08 06:10:17 UTC
Created attachment 4659 [details]
Level 10 log of a failed windows 98 login
Comment 3 Volker Lendecke 2009-09-08 06:11:42 UTC
99% this is a duplicate of bug 6551. Please try the patch from there.

Thanks,

Volker

*** This bug has been marked as a duplicate of bug 6551 ***