Bug 664 - configure ignores local kerberos installation in favor of Sun package
configure ignores local kerberos installation in favor of Sun package
Status: RESOLVED DUPLICATE of bug 433
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.0
All Solaris
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 10:28 UTC by Eric Boehm
Modified: 2005-11-14 09:25 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Boehm 2003-10-21 10:28:21 UTC
I have been unable to get configure to find the correct kerberos files if the
SUN packages are installed. I specified the kerberos file locations in the
arguments to configure. My configure line is

CC='cc' CXX=CC \
CPPFLAGS='-I/usr/local/include -I/usr/local/openldap/include
-I/usr/local/sasl/include -I/usr/local/kerberos/include
-I/usr/local/BerkeleyDB.4.1/include -I/usr/local/openssl/include' \
CFLAGS='-xarch=v9a' \
LDFLAGS='-L/usr/local/lib/sparcv9 -L/usr/local/openldap/lib
-L/usr/local/sasl/lib -L/usr/local/kerberos/lib -L/usr/local/BerkeleyDB.4.1/lib
-L/usr/local/openssl/lib -R\\$$ORIGIN -R/usr/local/lib/sparcv9
-R/usr/local/openldap/lib -R/usr/local/sasl/lib -R/usr/local/kerberos/lib
-R/usr/local/BerkeleyDB.4.1/lib -R/usr/local/openssl/lib' \
./configure \
--with-readline \
--with-libiconv=/usr/local \
--with-ldap \
--with-krb5=/usr/local/kerberos \
--with-ldapsam \
--with-automount \
--with-libsmbclient \
--with-acl-support \
--with-winbind \
--prefix=/usr/local

The workaround has been to temporarily move the SUN package files out of the way
while building Samba.
Comment 1 Andrew Bartlett 2003-10-22 16:26:21 UTC
I'm pretty sure this is the same bug.

*** This bug has been marked as a duplicate of 433 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:25:51 UTC
database cleanup