Bug 433 - with-krb5 ignores location specified
with-krb5 ignores location specified
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0
Other Solaris
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
: 600 664 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 08:49 UTC by Christopher Bowman
Modified: 2004-12-01 09:17 UTC (History)
4 users (show)

See Also:


Attachments
Use krb5-config from --with-krb5 directory (2.63 KB, patch)
2003-09-10 21:17 UTC, Tim Potter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Bowman 2003-09-10 08:49:44 UTC
The with-krb5 option ignores the location specified and attempts to locate the
kerberos installation automatically.

This is a problem when attempting to compile against hemdal on a machine with
both MIT krb5 and heimdal installed.

configure options:
./configure --prefix=/usr/local --with-readline
--with-privatedir=/etc/samba/private --with-configdir=/etc/samba
--with-lockdir=/var/samba/locks --localstatedir=/var/samba
--with-ssl=/usr/local/ssl --with-sslinc=/usr/local/ssl/include
--with-krb5=/usr/heimdal

results in the following output by configure:
Using libraries:
    LIBS = -lsec -lgen -lresolv -lsocket -lnsl -ldl
    KRB5_LIBS =  -L/usr/krb5/lib -R/usr/krb5/lib -lgssapi_krb5 -lkrb5 -lk5crypto
-lcom_err -lgen
    LDAP_LIBS =  -llber -lldap
    AUTH_LIBS =
Comment 1 Tim Potter 2003-09-10 18:59:05 UTC
assigning to me
Comment 2 Tim Potter 2003-09-10 21:17:14 UTC
Created attachment 134 [details]
Use krb5-config from --with-krb5 directory

Here's the start of a patch to fix this.  Configure will now detect and use a
krb5-config in the --with-krb5 directory.  Samba still doesnt't compile with
both MIT and Heimdal kerberos installed if MIT is installed in /usr/include.
Comment 3 Tim Potter 2003-09-10 21:21:17 UTC
Moving to Samba HEAD product.  The configure scripts are too fragile to be poked
at just before a release.
Comment 4 Tim Potter 2003-10-11 17:28:55 UTC
*** Bug 600 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Bartlett 2003-10-16 16:55:01 UTC
Bring this back to Samba 3.0 - it's not just a HEAD problem.
Comment 6 Andrew Bartlett 2003-10-22 16:26:23 UTC
*** Bug 664 has been marked as a duplicate of this bug. ***
Comment 7 Gerald (Jerry) Carter 2003-12-07 23:15:37 UTC
will someone do something with this ?  Thanks.
Comment 8 Gerald (Jerry) Carter 2003-12-12 08:28:00 UTC
reseting target milestone.  3.0.1 has been frozen.  WIll have to 
re-evaluate these.
Comment 9 Gerald (Jerry) Carter 2004-10-29 07:33:26 UTC
workaround is to set CPPFLASG, CFLAGS, and LDFLAGS.
Comment 10 Diego Remolina 2004-12-01 09:17:46 UTC
(In reply to comment #9)
> workaround is to set CPPFLASG, CFLAGS, and LDFLAGS.
Actually I do not have kerberos installed, but by default on Solaris 9, the
gssapi header files are installed from the package SUNWhea

This does not work even on samba-3.0.9:

[oak source]$ printenv | grep FLAGS
CPPFLAGS=-I/opt/local/include -I/opt/local/include/sasl
LDFLAGS=-L/opt/local/lib -L/opt/local/lib/sasl2
CFLAGS=-O2 -mcpu=v9

Then I run configure:[oak source]$ ./configure
--prefix=/opt/local/encap/samba-3.0.9/samba--sysconfdir=/etc/samba
--localstatedir=/var/samba --with-privatedir=/etc/samba/private
--with-configdir=/etc/samba --with-smbwrapper --with-ldap --with-automount
--with-syslog --with-quotas --with-acl-support--with-krb5=/opt/local

Then when i run make,
There is an error in dynconfig.c about the header files conflicting between:
/usr/include/gssapi (from the SUNWhea package) and
/opt/local/incude (from the heimdal package).

I can send config.log upon request.

Diego