Bug 6617 - wbinfo search for wrong directory holding winbindd pipe
wbinfo search for wrong directory holding winbindd pipe
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
Other Linux
: P3 normal
: ---
Assigned To: Kai Blin
Matthias Dieter Wallnöfer
:
: 5001 (view as bug list)
Depends on:
Blocks: 6600
  Show dependency treegraph
 
Reported: 2009-08-06 17:40 UTC by Matthieu Patou
Modified: 2009-09-11 03:32 UTC (History)
1 user (show)

See Also:


Attachments
Patch for build system in order to overide SOCKET location (929 bytes, patch)
2009-09-10 14:36 UTC, Matthieu Patou
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Patou 2009-08-06 17:40:26 UTC
As 4f147388c0512fc291cc53764c017d7117154afc, wbinfo one more time is looking at /tmp/.winbindd dir for finding the winbind pipe.

The pipe is by default defined in nsswitch/winbind_struct_protocol.h
with the constant :WINBINDD_SOCKET_DIR

for samba binary the compilation took place with this CFLAG :

-DWINBINDD_SOCKET_DIR=$(winbindd_socket_dir)

but for wbinfo no flag is passed. and it's not so simple to pass because it seems that s3 build do not define winbindd_socket_dir and would lead to pb for them
Comment 1 Matthias Dieter Wallnöfer 2009-08-07 03:24:51 UTC
Kai is the winbind guy.
Comment 2 Kai Blin 2009-08-07 03:59:34 UTC
I have to admit that I fail to see how this patch could break wbinfo.

Which wbinfo are you trying to use against which winbind server?

The S3 wbinfo will only work against S3 winbindd, the S4 wbinfo will only work against S4 winbind. Some of the features might accidently work S3<->S4, but currently that's not supported.
Comment 3 Matthieu Patou 2009-08-07 04:13:04 UTC
I use the version for s4 with a samba4 server on a freshly recompile samba.
Comment 4 Kai Blin 2009-08-07 06:37:54 UTC
*** Bug 5001 has been marked as a duplicate of this bug. ***
Comment 5 Kai Blin 2009-08-28 06:01:03 UTC
Ok, I've got it reproduced, now I just need to find out how to best get the path into the build system.
Comment 6 Matthieu Patou 2009-09-10 14:36:23 UTC
Created attachment 4681 [details]
Patch for build system in order to overide SOCKET location
Comment 7 Matthias Dieter Wallnöfer 2009-09-11 03:32:05 UTC
Fixed! Thanks to Matthieu for his elegant patch!