Bug 6556 - Can't access share after upgrading to 3.4.0
Can't access share after upgrading to 3.4.0
Status: RESOLVED DUPLICATE of bug 6551
Product: Samba 3.4
Classification: Unclassified
Component: File services
x86 Windows NT
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2009-07-16 07:55 UTC by Marc Muehlfeld
Modified: 2009-07-20 02:16 UTC (History)
0 users

See Also:

NT4 Workstation Level 10 Logfile (205.03 KB, application/octet-stream)
2009-07-16 07:56 UTC, Marc Muehlfeld
no flags Details
Patch for 3.4.0. (904 bytes, patch)
2009-07-16 16:00 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2009-07-16 07:55:05 UTC
I have one NT4 client (a medical device, that can't be replaced) that successfully run with samba yet. On this computer, the user is allways logged on locally and not to the domain (the medical software only run on this one local account). That's why the share on the PDC is allways mounted by "net use" through a desktop-link. But the workstation is part of the domain.

After upgrading my PDC to 3.4.0, the share can't be mounted any more. NT4 allways says "System error 58 has occurred".
Comment 1 Marc Muehlfeld 2009-07-16 07:56:40 UTC
Created attachment 4431 [details]
NT4 Workstation Level 10 Logfile
Comment 2 Jeremy Allison 2009-07-16 16:00:06 UTC
Created attachment 4434 [details]
Patch for 3.4.0.

This will fix it. It's the same issue as bug #6551 (SessionsetupX + TconX).
Comment 3 Jeremy Allison 2009-07-16 16:00:43 UTC
This is a duplicate of #6551. Get the patch from here, or there.

*** This bug has been marked as a duplicate of bug 6551 ***
Comment 4 Marc Muehlfeld 2009-07-20 02:16:40 UTC
I patched the sources, recompiled samba and did some testings. Connections from NT4 are now possible like it should.