Bug 6486 - manpages won't display on Solaris 10
manpages won't display on Solaris 10
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Docs
3.3.5
Sparc Solaris
: P3 normal
: ---
Assigned To: Jelmer Vernooij
Samba Documentation QA Contact~
:
: 6831 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 08:12 UTC by Tom Crummey
Modified: 2012-05-08 10:12 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Crummey 2009-06-18 08:12:04 UTC
The samba man pages do not work on Solaris 10.
The problem is likely to be that the man pages now use mandoc macros instead of man.
Solaris does not ship with mandoc macros.

Example:

% nroff -man smb.conf.5
nroff: Out of temp file space; line 3339, file smb.conf.5



File Formats and Conventions                          SMB.CONF(5)

This error seems to be due to the .de toupper macro definition.
Other manpages just appear as blank.

A further problem when using groff (version 1.20.1) to convert the smb.conf.5 page to postscript, the font is not restored after the homedir map section, i.e. the remainder of the page is in typewriter font.
Comment 1 Karolin Seeger 2009-09-29 03:18:23 UTC
Jelmer, do you have an idea how to fix that properly?
Comment 2 Jelmer Vernooij 2009-09-29 05:29:21 UTC
Tom, can you confirm that removing the .de toupper macro definition fixes the issue?
Comment 3 Tom Crummey 2009-10-09 08:29:52 UTC
Hello Jelmer,

No, removing the .de toupper definition doesn't fix it. 
I think there's more than just one problem macro. The manpages won't work on Solaris because they're
designed to use the -mandoc macro set. Solaris uses the -man macro set.
Comment 4 Tom Crummey 2009-10-09 11:00:20 UTC
Hello again,

Just for reference, the man pages from samba-3.0.20 work OK.

Tom.
Comment 5 Jelmer Vernooij 2009-10-19 06:40:20 UTC
We haven't changed much in this regard though, so I would expect this to be an upstream docbook change. I'll ask upstream.
Comment 6 Ray Van Dolson 2010-02-05 13:14:11 UTC
This happens for us as well with Samba 3.0.37 on Solaris 10 (Sun bundled version).  The problem began occurring when we applied the following patches:

  122676-04: SunOS 5.10_x86: SunFreeware samba man pages patch
  122675-04: SunOS 5.10: SunFreeware samba man pages patch

I opened SR #72407588 with Sun for this issue but will point them to this bug as well.  Should I open another bug for the 3.0.x branch?
Comment 7 Karolin Seeger 2010-02-08 04:27:51 UTC
(In reply to comment #6)
> This happens for us as well with Samba 3.0.37 on Solaris 10 (Sun bundled
> version).  The problem began occurring when we applied the following patches:
> 
>   122676-04: SunOS 5.10_x86: SunFreeware samba man pages patch
>   122675-04: SunOS 5.10: SunFreeware samba man pages patch
> 
> I opened SR #72407588 with Sun for this issue but will point them to this bug
> as well.  Should I open another bug for the 3.0.x branch?

3.0 is out of maintenance, so it does not make sense to open another bug report.

Comment 8 SATOH Fumiyasu 2012-03-25 20:52:20 UTC
The smb.conf(5) from Samba 3.5.11 and 3.6.3 are useable on Solaris 10.
I think this bug was gone.
Comment 9 Karolin Seeger 2012-03-26 17:35:35 UTC
Thanks for your feedback!
Closing out bug report.

Karolin
Comment 10 Karolin Seeger 2012-05-08 10:12:49 UTC
*** Bug 6831 has been marked as a duplicate of this bug. ***