Bug 6831 - Solaris man pages
Solaris man pages
Status: RESOLVED DUPLICATE of bug 6486
Product: Samba 3.4
Classification: Unclassified
Component: Docs
Sparc Solaris
: P3 normal
: ---
Assigned To: John H Terpstra
Samba Documentation QA Contact~
Depends on:
  Show dependency treegraph
Reported: 2009-10-20 09:26 UTC by emil
Modified: 2012-05-08 10:12 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description emil 2009-10-20 09:26:21 UTC
This is more of a question - I might not be doing something right...

1. Seems like the formatting of the man pages is not compatible with Solaris 10 (same for Solaris 8). This is what I get as man page for all commands (relevant to the command of course):

xxxxx% man -M man smbpasswd
Reformatting page.  Please Wait... done

File Formats and Conventions                         SMBPASSWD(5)

Samba 3.4            Last change: 09/30/2009                    1

That is all. 
Looking trough the samba_3.4.2/source3/scripts/installman.sh script I can see that the man pages are just copied over to the destination man directory from samba_3.4.2/docs/manpages and contain all the details, but those are not displayed. I saw the GROFF variable being available in the script as the fourth argument in the installman.sh, so I decided to set it. Since groff is not part of the standard distribution I installed the freeware. "Groffing" the existing man pages gave me more that the above output, but all was just a dump of the file content - no formatting and not usable at all. At the same time the man pages as they are are perfectly readable on SUSE Linux we have in our environment. Are there any options I don't know about or the man pages were not being done with Solaris in mind?

2. When running configure I only get Makefile-noinclude. I run make using it and I get all compiled (using Sun Studio 11 compiler), but with a lot of warnings. It seems though all I have tested with so far (except the man pages is working).

3. Is there option (I can't see from the available from the configure) to compile without the ldb? Or the idea is ldb to be used as cornerstone for the future upgrade to Samba 4, which will use it, so even though we will not use it now it will be there to implement for the future releases.


Comment 1 SATOH Fumiyasu 2012-03-25 20:55:17 UTC
This bug is duplicate of Bug 6486, I think.
Comment 2 Karolin Seeger 2012-05-08 10:12:49 UTC
Seems to be fixed in current versions of Samba.
Closing out bug report.
Please feel free to re-open if it's still an issue in Samba 3.6.5.


*** This bug has been marked as a duplicate of bug 6486 ***