Bug 6118 - Samba 3.3.0: pdbedit -a core dumps
Samba 3.3.0: pdbedit -a core dumps
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Client tools
3.3.0
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 6117 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 03:59 UTC by hdejin
Modified: 2009-02-19 03:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hdejin 2009-02-17 03:59:08 UTC
Running pdbedit -a generates a coredump.

Problem seems to be in source/passdb/pdb_tdb.c tdbsam_new_rid().
db_sam is unintialised when dbwrap_change_uint32_atomic() gets invoked.

Sticking a tdbsam_open() before dbwrap_change_uint32_atomic()
seems to help.
Comment 1 hdejin 2009-02-17 04:02:43 UTC
*** Bug 6117 has been marked as a duplicate of this bug. ***
Comment 2 Karolin Seeger 2009-02-19 03:38:28 UTC
Closing out bug report. See bug #6117 for a patch.