Bug 6117 - Samba 3.3.0: pdbedit -a core dumps
Samba 3.3.0: pdbedit -a core dumps
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Client tools
3.3.0
x86 Windows XP
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
: 6119 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 03:58 UTC by hdejin
Modified: 2009-02-19 03:39 UTC (History)
1 user (show)

See Also:


Attachments
Patch for 3.3.0. (1.32 KB, patch)
2009-02-17 15:45 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hdejin 2009-02-17 03:58:56 UTC
Running pdbedit -a generates a coredump.

Problem seems to be in source/passdb/pdb_tdb.c tdbsam_new_rid().
db_sam is unintialised when dbwrap_change_uint32_atomic() gets invoked.

Sticking a tdbsam_open() before dbwrap_change_uint32_atomic()
seems to help.
Comment 1 hdejin 2009-02-17 04:02:43 UTC

*** This bug has been marked as a duplicate of 6118 ***
Comment 2 Jeremy Allison 2009-02-17 15:45:05 UTC
Created attachment 3941 [details]
Patch for 3.3.0.

Fixed by the following commit.
Jeremy.
Comment 3 Jeremy Allison 2009-02-17 15:52:51 UTC
*** Bug 6119 has been marked as a duplicate of this bug. ***
Comment 4 Karolin Seeger 2009-02-19 03:39:35 UTC
Closing out bug report.
Please re-open if it's still an issue.

Thanks for reporting!