Bug 6034 - Winbindd dumps core when listing trusted domain users/groups
Winbindd dumps core when listing trusted domain users/groups
Status: RESOLVED DUPLICATE of bug 6130
Product: Samba 3.2
Classification: Unclassified
Component: Winbind
3.2.6
x64 Windows XP
: P3 critical
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks: 6130
  Show dependency treegraph
 
Reported: 2009-01-14 13:50 UTC by François Legal
Modified: 2009-05-11 08:46 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description François Legal 2009-01-14 13:50:12 UTC
The setup is as follows:
DOM A (trusted domain) with custom Samba 3.2.4 build  PDC on linux 2.6.27 with LDAP passwd backend
DOM B (trusting domain) with custom Samba 3.2.6 build PDC on linux 2.6.24 with ldap passwd/idmap backend. Trust relation to DOM A was established (and working) since 3.2

After upgrade DOM B PDC from 3.2.4 to 3.2.6 a experienced some winbindd crashes that seemd to happen while a DOM A trusted user was logging out. I could have it reproduced by issuing a getent group command right after running samba.

I did build DOM B samba with :
# ./configure --with-aio-support --with-sendfile --with-acl-support --with-quotas --with-utmp  --with-cifsmount --with-ldap --disable-largefile  --enable-cups --with-mandir=/usr/local/man  --with-logfilebase=/var/log/samba  --with-configdir=/etc/samba  --with-piddir=/var/run/samba  --with-lockdir=/var/lib/samba  --with-privatedir=/etc/samba/private  --disable-largefile --enable-developer
# make
# make install
# cp nsswitch/libnss* /usr/local/samba/lib/nssinfo
(/lib/libnss_win*.so.2 linked to /usr/local/samba/lib/nssinfo for easy upgrade)

This is the winbindd log from startup to crash :
[2009/01/14 20:30:51,  0] winbindd/winbindd.c:main(1132)
  winbindd version 3.2.6 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2008
[2009/01/14 20:30:51,  0] winbindd/winbindd_cache.c:initialize_winbindd_cache(2374)
  initialize_winbindd_cache: clearing cache and re-creating with version number 1
[2009/01/14 20:31:02,  0] winbindd/idmap.c:idmap_init(396)
  idmap_init: Ignoring domain DOMB
[2009/01/14 20:31:02,  0] lib/fault.c:fault_report(40)
  ===============================================================
[2009/01/14 20:31:02,  0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 6200 (3.2.6)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2009/01/14 20:31:02,  0] lib/fault.c:fault_report(43)
  
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2009/01/14 20:31:02,  0] lib/fault.c:fault_report(44)
  ===============================================================
[2009/01/14 20:31:02,  0] lib/util.c:smb_panic(1657)
  smb_panic: clobber_region() last called from [sid_to_fstring(178)]
[2009/01/14 20:31:02,  0] lib/util.c:smb_panic(1663)
  PANIC (pid 6200): internal error
[2009/01/14 20:31:02,  0] lib/util.c:log_stack_trace(1767)
  BACKTRACE: 16 stack frames:
   #0 /usr/local/samba/sbin/winbindd(log_stack_trace+0x1c) [0x55555567ccbc]
   #1 /usr/local/samba/sbin/winbindd(smb_panic+0x3d) [0x55555567cdad]
   #2 /usr/local/samba/sbin/winbindd [0x5555556685f0]
   #3 /lib/libc.so.6 [0x2ad747ec6110]
   #4 /usr/local/samba/sbin/winbindd(strlower_m+0xd) [0x5555556730ed]
   #5 /usr/local/samba/sbin/winbindd(fill_domain_username_talloc+0x33) [0x5555555d4883]
   #6 /usr/local/samba/sbin/winbindd [0x5555555f2c74]
   #7 /usr/local/samba/sbin/winbindd [0x5555555f4f08]
   #8 /usr/local/samba/sbin/winbindd [0x5555555de3be]
   #9 /usr/local/samba/sbin/winbindd [0x5555555d0604]
   #10 /usr/local/samba/sbin/winbindd [0x5555555d1e3e]
   #11 /usr/local/samba/sbin/winbindd(winbindd_getgrent+0x89e) [0x5555555d38ae]
   #12 /usr/local/samba/sbin/winbindd [0x5555555cd1ee]
   #13 /usr/local/samba/sbin/winbindd(main+0xb6a) [0x5555555cc73a]
   #14 /lib/libc.so.6(__libc_start_main+0xda) [0x2ad747eb34ca]
   #15 /usr/local/samba/sbin/winbindd [0x5555555caa0a]
[2009/01/14 20:31:02,  0] lib/util.c:smb_panic(1668)
  smb_panic(): calling panic action [/bin/sleep 90000]

The process tree is as follows :
# ps axf
...
 6200 ?        Ts     0:00 /usr/local/samba/sbin/winbindd -D -s /etc/samba/smb.c
 6201 ?        S      0:00  \_ /usr/local/samba/sbin/winbindd -D -s /etc/samba/s
 6202 ?        S      0:00  \_ /usr/local/samba/sbin/winbindd -D -s /etc/samba/s
 6203 ?        S      0:00  \_ /usr/local/samba/sbin/winbindd -D -s /etc/samba/s
 6207 ?        S      0:00  \_ /bin/sleep 90000
...

The backtrace from gdb (which does not seem to produce anything interesting):
#  gdb --pid 6200
GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Attaching to process 6200
Reading symbols from /usr/local/samba/sbin/winbindd...done.
Using host libthread_db library "/lib/libthread_db.so.1".

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff639ff000
0x00002ad747f28715 in ?? ()
(gdb) bt
#0  0x00002ad747f28715 in ?? ()
#1  0xffffffffffffffc0 in ?? ()
#2  0x00007fff6390904c in ?? ()
#3  0x0000000000000001 in ?? ()
#4  0x00002ad747ed1721 in ?? ()
#5  0x0000000000000001 in ?? ()
#6  0x0000000000010000 in ?? ()
#7  0x0000000000000000 in ?? ()
(gdb) The program is running.  Quit anyway (and detach it)? (y or n) y
Detaching from program: /usr/local/samba/sbin/winbindd, process 6200

# gdb --pid 6201
GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Attaching to process 6201
Reading symbols from /usr/local/samba/sbin/winbindd...done.
Using host libthread_db library "/lib/libthread_db.so.1".

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff639ff000
0x00002ad747f59a45 in ?? ()
(gdb) bt
#0  0x00002ad747f59a45 in ?? ()
#1  0x0000555555686ac3 in ?? ()
#2  0x0000000000000000 in ?? ()
(gdb) The program is running.  Quit anyway (and detach it)? (y or n) y
Detaching from program: /usr/local/samba/sbin/winbindd, process 6201

# gdb --pid 6202
GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Attaching to process 6202
Reading symbols from /usr/local/samba/sbin/winbindd...done.
Using host libthread_db library "/lib/libthread_db.so.1".

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff639ff000
0x00002ad747f59a45 in ?? ()
(gdb) bt
#0  0x00002ad747f59a45 in ?? ()
#1  0x0000555555686ac3 in ?? ()
#2  0x00007fff639096f0 in ?? ()
#3  0x00000016480d00e0 in ?? ()
#4  0x0000000081edcd6c in ?? ()
#5  0xffffffffff60004a in ?? ()
#6  0x0000555555a9c420 in ?? ()
#7  0x0000555555aa1cc0 in ?? ()
#8  0x00007fff639096f0 in ?? ()
#9  0x0000555555b129f0 in ?? ()
#10 0x0000000000000000 in ?? ()
(gdb) The program is running.  Quit anyway (and detach it)? (y or n) y
Detaching from program: /usr/local/samba/sbin/winbindd, process 6202

# gdb --pid 6203
GNU gdb 6.4.90-debian
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Attaching to process 6203
Reading symbols from /usr/local/samba/sbin/winbindd...done.
Using host libthread_db library "/lib/libthread_db.so.1".

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff639ff000
0x00002ad747f59a45 in ?? ()
(gdb) bt
#0  0x00002ad747f59a45 in ?? ()
#1  0x0000555555686ac3 in ?? ()
#2  0x00007fff63909650 in ?? ()
#3  0x0000001655b02d80 in ?? ()
#4  0x0000000081eca87e in ?? ()
#5  0xffffffffff60004a in ?? ()
#6  0x0000000000000000 in ?? ()
(gdb) The program is running.  Quit anyway (and detach it)? (y or n) 
Detaching from program: /usr/local/samba/sbin/winbindd, process 6203
Comment 1 François Legal 2009-01-14 14:03:27 UTC
Oops, forgot my smb.conf.

[global]
        workgroup = DOMB
        server string = %h server
        interfaces = bond0, lo
        bind interfaces only = Yes
        passdb backend = ldapsam:ldapi://%2fvar%2frun%2fslapd%2fldapi/
        client NTLMv2 auth = Yes
        min protocol = LANMAN1
        reset on zero vc = Yes
        time server = Yes
        server signing = auto
        load printers = No
        printcap name = cups
        cups server = localhost
        logon script = startup.bat
        logon path = \\blg-srv-01\profiles\%U
        logon drive = z:
        domain logons = Yes
        os level = 65
        preferred master = Yes
        domain master = Yes
        wins proxy = Yes
        wins support = Yes
        ldap admin dn = cn=SambaAdmin,dc=internal,dc=domb,dc=fr
        ldap group suffix = ou=Groups
        ldap machine suffix = ou=Machines
        ldap passwd sync = Yes
        ldap suffix = dc=internal,dc=domb,dc=fr
        ldap user suffix = ou=People
        utmp = Yes
        host msdfs = No
        idmap domains = DOMB, DOMA
        idmap alloc backend = ldap
        winbind enum users = Yes
        winbind enum groups = Yes
        winbind use default domain = Yes
        idmap alloc config:range = 1000 - 199999
        idmap alloc config:ldap_url = ldapi://%2fvar%2frun%2fslapd%2fldapi/
        idmap alloc config:ldap_user_dn = cn=SambaIdmap,dc=internal,dc=domb,dc=fr
        idmap alloc config:ldap_base_dn = ou=Alloc,ou=Idmaps,dc=internal,dc=domb,dc=fr
        idmap config DOMA:range = 20000-199999
        idmap config DOMA:ldap_url = ldapi://%2fvar%2frun%2fslapd%2fldapi/
        idmap config DOMA:ldap_user_dn = cn=SambaIdmap,dc=internal,dc=arcaneo,dc=fr
        idmap config DOMA:ldap_base_dn = ou=DomA,ou=Idmaps,dc=internal,dc=domb,dc=fr
        idmap config DOMA:backend = ldap
        idmap config BOMB:readonly = Yes
        idmap config DOMB:backend = nss
        ldapsam:editposix = Yes
        ldapsam:trusted = Yes
        hosts allow = 10.212.0.0/15, 10.210.0.0/15, 127.0.0.1
        map acl inherit = Yes
        cups options = raw

[print$]
        comment = Printer Drivers
        path = /home/admin/print
        write list = @adm
        create mask = 0664
        directory mask = 0775
        guest ok = Yes
        browseable = No

[netlogon]
        comment = Network logon service
        path = /home/admin/netlogon
        write list = @adm

[profiles]
        comment = User's profile share
        path = /home/profiles
        read only = No
        profile acls = Yes
        browseable = No

[homes]
        comment = Home Directories
        read only = No
        create mask = 0600
        directory mask = 0700
        browseable = No

Comment 2 François Legal 2009-02-17 12:08:26 UTC
I could finally find what was causing this crash.

I had some non samba users in samba domain groups of trusted PDC, and when winbindd was trying to enumerate the group members, it was crashing.

Comment 3 François Legal 2009-05-11 08:46:44 UTC
(In reply to comment #2)
> I could finally find what was causing this crash.
> 
> I had some non samba users in samba domain groups of trusted PDC, and when
> winbindd was trying to enumerate the group members, it was crashing.
> 

Sorry, but this one is the same as 6130. As 6130 is fixed (thanks to Volker Lendecke) I think this one can be closed to.

François

*** This bug has been marked as a duplicate of bug 6130 ***