Bug 6130 - Winbind crashes when enumerating trsuted domain groups
Winbind crashes when enumerating trsuted domain groups
Status: RESOLVED FIXED
Product: Samba 3.3
Classification: Unclassified
Component: Winbind
3.3.0
x64 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
: 6034 (view as bug list)
Depends on: 6034
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 02:11 UTC by François Legal
Modified: 2009-05-11 08:46 UTC (History)
1 user (show)

See Also:


Attachments
samba configuration file (6.41 KB, application/octet-stream)
2009-02-25 10:34 UTC, François Legal
no flags Details
level 10 log of winbindd (375.71 KB, application/octet-stream)
2009-03-15 07:08 UTC, François Legal
no flags Details
patch (1.33 KB, patch)
2009-03-16 07:21 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description François Legal 2009-02-20 02:11:44 UTC
I found a bug in winbindd that make it crash when enumerating domain groups which have non domain user members.

I found this happening in 3.2.6 and 3.3.0
Comment 1 Volker Lendecke 2009-02-25 09:38:38 UTC
Can you add your smb.conf and a debug level 10 log of the winbind process that crashed? I've just tried with latest v3-3 code with winbind as domain member, and it worked fine for me.

Volker
Comment 2 François Legal 2009-02-25 10:31:02 UTC
(In reply to comment #1)
> Can you add your smb.conf and a debug level 10 log of the winbind process that
> crashed? I've just tried with latest v3-3 code with winbind as domain member,
> and it worked fine for me.
> 
> Volker
> 

Actually, I did not keep that log. I'll try to rebuild, reproduce and send it as soon as I can.
Comment 3 François Legal 2009-02-25 10:34:36 UTC
Created attachment 3956 [details]
samba configuration file
Comment 4 François Legal 2009-03-15 07:08:54 UTC
Created attachment 3994 [details]
level 10 log of winbindd

Here comes the log.

By retesting it, I realized I made a mistake in the diagnostic.
The problem is when a samba machine account is member of a samba domain group from the trusted domain. It crashes during the members enumeration.
Comment 5 Volker Lendecke 2009-03-16 07:21:25 UTC
Created attachment 3996 [details]
patch

Can you try the attached (fully untested) patch?

I have not checked it in yet, waiting for your ack that it helps.

Thanks,

Volker
Comment 6 François Legal 2009-03-17 14:41:29 UTC
The patch fixes the problem. Winbind no more crashes, and the enumeration takes place correctly.
Thank you for the good work.

François
Comment 7 François Legal 2009-05-11 08:46:44 UTC
*** Bug 6034 has been marked as a duplicate of this bug. ***