Bug 5499 - Samba 3.0.29 - ntlm_auth did'nt work on PDC + winbindd
Samba 3.0.29 - ntlm_auth did'nt work on PDC + winbindd
Status: RESOLVED DUPLICATE of bug 5489
Product: Samba 3.0
Classification: Unclassified
Component: ntlm_auth tool
3.0.29
x86 Linux
: P3 normal
: none
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 05:15 UTC by Michael
Modified: 2008-05-29 10:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2008-05-29 05:15:16 UTC
Hi there,

since Samba 3.0.29, the ntlm_auth stopped working.
Configuration: Take a look at bug 4886. The content of smb.conf is equal.
Samba is running in PDC mode + winbindd is running.

ntlm_auth with 3.0.28a:
ntlm_auth --username=<user> --password=<password>
results with:
NT_STATUS_OK: Success (0x0)

All daemons (smbd, nmbd, winbindd) are running.


ntlm_auth with 3.0.29:
ntlm_auth --username=<user> --password=<password>
results with:
NT_STATUS_NO_LOGON_SERVERS: No logon servers (0xc000005e)

All daemons (smbd, nmbd, winbindd) are up.


On a samba-machine acting as a member server (no PDC, winbindd up), the mentioned operation
is working (3.0.28a / 3.0.29)as expected: "NT_STATUS_OK: Success (0x0)".

So I think, there is a bug, if the machine is running in PDC mode + winbindd running.

At the moment, I went back to version 3.0.28a, cause this version works like it should be.

Greets,
Michael
Comment 1 Jeremy Allison 2008-05-29 10:38:58 UTC
This is a duplicate of #5489. I'm tracking the problem there.
Jeremy.


*** This bug has been marked as a duplicate of 5489 ***