Bug 4886 - Linux CIFS-access problem since samba 3.0.25(a/b/c) / 3.0.27(a)
Linux CIFS-access problem since samba 3.0.25(a/b/c) / 3.0.27(a)
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.27
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 05:16 UTC by Michael
Modified: 2007-11-27 02:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2007-08-15 05:16:02 UTC
Hi there,

at first, the following scenario is used in our environment:

Server-Side:
- One Samba PDC using 3.0.24 release with TDB-backend.
- Some Samba member servers serving files, home-dirs, etc.

Client-Side:
- Windows XP-Clients.
- Windows Vista Clients (testing).
- some Linux Ubuntu Distro (Feisty) Clients, using CIFS to access the samba-shares.
fstab-entry of the Ubuntu-clients:
//server/share /media/files_on_server cifs credentials=/home/user/.smbcredentials,dom=domain,directio,users,noperm,iocharset=utf8,nolock,soft,intr,rsize=8192,wsize=8192 0 0

The problem:
Since using release 3.0.25(a/b) on the samba-member servers,
- accessing the shares by using a Linux Ubuntu Client through CIFS-mount is very slow (!!!!). Sometimes you have to wait centuries to get the directory-contents.
- accessing the shares by a Windows Client is at normal speed.

After rolling back to 3.0.24 on the samba-member servers:
- accessing the shares by using a Linux Ubuntu Client through CIFS-mount work like it should be (normal speed).

What I've found out is:
If we use Samba 3.0.25(a/b) on the member-servers and unset the "msdfs root"-parameter from "yes" to "no", the access-speed of the Ubuntu-Clients is at normal speed.
Reverting the parameter to "yes" results in the mentioned problem.

Rolling back to 3.0.24 and using "msdfs root = yes" results in NO problem.

smb.conf on Samba-member server:

[global]
       unix charset = ISO8859-1
       name resolve order = host wins bcast
       display charset = ISO8859-1
       encrypt passwords = yes
       preferred master = no
       domain master = auto
       domain logons = no
       local master = yes
       log level = 1
       os level = 20
       workgroup = DOMAIN
       netbios name = %h
       interfaces = eth0 lo
       server string = %h on SMB %v
       allow hosts = 127.0.0.1 10.0.1.0/24 0.0.0.0/0
       deny hosts = ALL EXCEPT 10.0.1.0/24 127.0.0.1 0.0.0.0/0
       keep alive = 30
       read raw = yes
       write raw = yes
       socket options = SO_KEEPALIVE TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
       passdb backend = tdbsam:/etc/samba/private/passdb.tdb
       host msdfs = yes
       msdfs root = yes
       security = domain
       password server = *
       idmap uid = 10000-20000
       idmap gid = 10000-20000
       winbind enum users = yes
       winbind enum groups = yes
       winbind cache time = 100
       template homedir = /home/%U
       load printers = yes
       printing = cups
       printcap = cups
       show add printer wizard = yes
       deadtime = 15
       write cache size = 1048576

[homes]
       path = /home/%S
       comment = %U Home Dir
       browseable = no
       admin users = @"domain\domain admins"
       invalid users = @"domain\domain guests"
       valid users = "domain\%S",@"domain\domain admins"
       writeable = yes
       write list = "domain\%U",@"domain\domain admins"
       guest ok = no
       inherit owner = yes
       inherit permissions = yes
       force user = "domain\%U"
       force group = "domain\domain admins"
       guest ok = no

[Files]
       map acl inherit = yes
       dos filemode = yes
       inherit acls = yes
       inherit permissions = yes
       browseable = yes
       writeable = yes
       guest ok = no
       path = /share-point/files
       comment = FILE01 LV
       vfs objects = recycle
       recycle:repository = SERVER_RECYCLE_BIN
       recycle:keeptree = Yes
       recycle:touch = Yes
       recycle:versions = Yes

[Files-test]
       map acl inherit = yes
       dos filemode = yes
       inherit acls = yes
       inherit permissions = yes
       browseable = yes
       writeable = yes
       guest ok = no
       path = /mnt
       comment = FILE01 backup

[printers]
       comment = Printer
       printable = yes
       guest ok = no
       browseable = yes
       path = /var/spool/samba
       admin users =

[print$]
       comment = Printer Driver Download Area
       write list = @"domain\domain admins"
       guest ok = no
       browseable = yes
       path = /etc/samba/config/printer
       read only = yes
       admin users =

Is there any solution known to solve this problem?

Regards,
Michael
Comment 1 Michael 2007-08-23 08:23:37 UTC
Hi there,

tested the scenario with 3.0.25c.
Same problem at all. :((


Greets,
Michael
Comment 2 Michael 2007-09-12 03:47:05 UTC
...and again tested the scenario with 3.0.26a.
Nothing has changed. Problem still exists.


Greets,
Michael
Comment 3 Gerald (Jerry) Carter 2007-09-12 05:54:57 UTC
Sounds lie a possible client issue?  Have you queried the 
linux-cifs-client ml hosted on samba.org about this?
I don't want to reassign this to the cifs client bugtracking 
just yet, but it would be good to at least follow up
on that end some.
Comment 4 Michael 2007-09-12 16:20:04 UTC
Hi Jerry,

it's a little bit strange that everything works with samba 3.0.24 and all versions after 3.0.24 did'nt work anymore (remember: switching parameter "msdfs root" to "no" solves the problem with 3.0.25 -> 26a, but this can't be the real solutions, cause we have a mixed environment (Windows and Linux Clients)).
So I think, it is a server and not a client problem.

But I've tried something different to exclude the problem on the client side:
I downloaded the latest cifs-implementation (new-cifs-backport) version 1.50 and compiled the module(s) for the latest kernel (2.6.22.6).
But this did'nt solve the problem. :((

Now I'll post the problem, as you suggested, to the linux-cifs-client mailinglist.
But my personal optinion is, that the problem is caused by the server-side.

Greets,
Michael
Comment 5 Michael 2007-11-27 02:11:55 UTC
Hi there,

nothing has changed.
I've tried version 3.0.27a, but the mentioned error occures.
The cifs team ignored my bug-report.
So, who is to blame for it? :)

Now I will get back to 3.0.24, because there are to many problems since the massive changes from 3.0.25 to 3.0.27a.
Another problem (since version 3.0.25) is descriped in bug 4973.

Greets,
Michael