Bug 5473 - OS-X Leopard Rsync 3.0.3pre2 make check failures
OS-X Leopard Rsync 3.0.3pre2 make check failures
Status: CLOSED DUPLICATE of bug 5470
Product: rsync
Classification: Unclassified
Component: core
3.0.3
Other Solaris
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 16:24 UTC by Bob Friesenhahn
Modified: 2013-02-18 13:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Friesenhahn 2008-05-17 16:24:04 UTC
Note that this test run was run as 'root' but a test is skipped because it claims that it is not run as root.  My previous FreeBSD test run was also done as 'root' and skips for the same reason.

rsync_bin=`pwd`/rsync /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/runtests.sh
grep: /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/config.h: No such file or directory
grep: /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/config.h: No such file or directory
============================================================
/home/bfriesen/src/network/rsync/rsync-3.0.3pre2/runtests.sh running in /Users/bfriesen/build/rsync-3.0.3pre2
    rsync_bin=/Users/bfriesen/build/rsync-3.0.3pre2/rsync 
    srcdir=/home/bfriesen/src/network/rsync/rsync-3.0.3pre2
    TLS_ARGS=
    testuser=root
    os=Darwin scrappy.simplesystems.org 9.2.2 Darwin Kernel Version 9.2.2: Tue Mar  4 21:23:43 PST 2008; root:xnu-1228.4.31~1/RELEASE_PPC Power Macintosh
    preserve_scratch=no
    scratchbase=/Users/bfriesen/build/rsync-3.0.3pre2/testtmp
PASS    00-hello
PASS    acls
PASS    backup
PASS    batch-mode
PASS    chgrp
PASS    chmod-option
PASS    chmod-temp-dir
PASS    chmod
SKIP    chown-fake (Can't chown (probably need root))
PASS    chown
PASS    compare-dest
PASS    daemon-gzip-download
PASS    daemon-gzip-upload
PASS    daemon
SKIP    default-acls (I don't know how to use your setfacl command)
PASS    delete
SKIP    devices-fake (Can't create char device node)
PASS    devices
SKIP    dir-sgid (Your filesystem doesn't use directory setgid; maybe it's BSD.)
PASS    duplicates
PASS    exclude
PASS    executability
PASS    fuzzy
PASS    hands
----- hardlinks log follows
Testing for symlinks using 'test -h'
Running: "/Users/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivv '/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' '/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
sending incremental file list
created directory /Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to
delta-transmission disabled for local transfer or --whole-file
cd+++++++++ ./
>f+++++++++ name3
>f+++++++++ name4
>f+++++++++ text
hf+++++++++ name2 => name3
hf+++++++++ name1 => name3
total: matches=0  hash_hits=0  false_alarms=0 data=753189

sent 753515 bytes  received 98 bytes  1507226.00 bytes/sec
total size is 753223  speedup is 1.00
-------------
check how the directory listings compare with diff:

-------------
check how the files compare with diff:

-------------
Running: "/Users/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivv --no-whole-file '/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' '/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
sending incremental file list
delta-transmission enabled
.d          ./
>f.s....... name1
.f          name4
.f          text
hf.s....... name2 => name1
hf.s....... name3 => name1
total: matches=0  hash_hits=0  false_alarms=0 data=17

sent 171 bytes  received 68 bytes  478.00 bytes/sec
total size is 753223  speedup is 3151.56
-------------
check how the directory listings compare with diff:

-------------
check how the files compare with diff:

-------------
        makepath /Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/subdir/down/deep
Running: "/Users/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivve 'support/lsh' --rsync-path='/Users/bfriesen/build/rsync-3.0.3pre2/rsync ' '/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' localhost:'/Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
opening connection using: support/lsh localhost "/Users/bfriesen/build/rsync-3.0.3pre2/rsync " --server -vvlHogDtpre.iL "--log-format=%i" . /Users/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/ 
rsync: Failed to exec support/lsh: No such file or directory (2)
rsync error: error in IPC code (code 14) at /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/pipe.c(84) [sender=3.0.3pre2]
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in IPC code (code 14) at /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/io.c(635) [sender=3.0.3pre2]
----- hardlinks log ends
FAIL    hardlinks
PASS    itemize
PASS    longdir
PASS    merge
PASS    missing
PASS    relative
SKIP    ssh-basic (Skipping SSH tests because ssh conection to localhost not authorised)
PASS    symlink-ignore
PASS    trimslash
PASS    unsafe-byname
PASS    unsafe-links
PASS    wildmatch
SKIP    xattrs (Unable to set an xattr)
------------------------------------------------------------
----- overall results:
      30 passed
      1 failed
      6 skipped
------------------------------------------------------------
overall result is 1
make: *** [check] Error 1
Comment 1 Wayne Davison 2008-05-17 16:50:54 UTC

*** This bug has been marked as a duplicate of 5470 ***