Bug 5470 - Make check failures on Solaris 10 with rsync 3.0.3pre2
Make check failures on Solaris 10 with rsync 3.0.3pre2
Status: CLOSED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.0.3
Other Solaris
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
:
: 5472 5473 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-17 15:37 UTC by Bob Friesenhahn
Modified: 2013-02-18 13:31 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Friesenhahn 2008-05-17 15:37:36 UTC
rsync_bin=`pwd`/rsync /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/runtests.sh
egrep: can't open "/home/bfriesen/src/network/rsync/rsync-3.0.3pre2/config.h"
egrep: can't open "/home/bfriesen/src/network/rsync/rsync-3.0.3pre2/config.h"
============================================================
/home/bfriesen/src/network/rsync/rsync-3.0.3pre2/runtests.sh running in /scratch/bfriesen/build/rsync-3.0.3pre2
    rsync_bin=/scratch/bfriesen/build/rsync-3.0.3pre2/rsync 
    srcdir=/home/bfriesen/src/network/rsync/rsync-3.0.3pre2
    TLS_ARGS=
    testuser=bfriesen
    os=SunOS freddy 5.10 Generic_127128-11 i86pc i386 i86pc
    preserve_scratch=no
/home/bfriesen/src/network/rsync/rsync-3.0.3pre2/runtests.sh: setacl: not found
    scratchbase=/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp
PASS    00-hello
SKIP    acls (I don't know how to use setfacl or chmod for ACLs)
PASS    backup
PASS    batch-mode
PASS    chgrp
PASS    chmod-option
PASS    chmod-temp-dir
PASS    chmod
SKIP    chown-fake (Rsync needs xattrs for fake device tests)
SKIP    chown (Can't chown (probably need root))
PASS    compare-dest
PASS    daemon-gzip-download
PASS    daemon-gzip-upload
PASS    daemon
SKIP    default-acls (I don't know how to use your setfacl command)
PASS    delete
SKIP    devices-fake (Rsync needs xattrs for fake device tests)
SKIP    devices (Rsync needs root/fakeroot for device tests)
SKIP    dir-sgid (The directory setgid bit vanished!)
PASS    duplicates
PASS    exclude
PASS    executability
PASS    fuzzy
PASS    hands
----- hardlinks log follows
Testing for symlinks using 'test -h'
Running: "/scratch/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivv '/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' '/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
sending incremental file list
created directory /scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to
delta-transmission disabled for local transfer or --whole-file
cd+++++++++ ./
>f+++++++++ name3
>f+++++++++ name4
>f+++++++++ text
hf+++++++++ name2 => name3
hf+++++++++ name1 => name3
total: matches=0  hash_hits=0  false_alarms=0 data=753189

sent 753523 bytes  received 98 bytes  1507242.00 bytes/sec
total size is 753223  speedup is 1.00
-------------
check how the directory listings compare with diff:

No differences encountered
-------------
check how the files compare with diff:

-------------
Running: "/scratch/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivv --no-whole-file '/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' '/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
sending incremental file list
delta-transmission enabled
.d          ./
>f.st...... name1
.f          name4
.f          text
hf.st...... name2 => name1
hf.st...... name3 => name1
total: matches=0  hash_hits=0  false_alarms=0 data=17

sent 179 bytes  received 68 bytes  494.00 bytes/sec
total size is 753223  speedup is 3049.49
-------------
check how the directory listings compare with diff:

No differences encountered
-------------
check how the files compare with diff:

-------------
        makepath /scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/subdir/down/deep
Running: "/scratch/bfriesen/build/rsync-3.0.3pre2/rsync  -aHivve 'support/lsh' --rsync-path='/scratch/bfriesen/build/rsync-3.0.3pre2/rsync ' '/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/from/' localhost:'/scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/'"
opening connection using: support/lsh localhost "/scratch/bfriesen/build/rsync-3.0.3pre2/rsync " --server -vvlHogDtpre.i "--log-format=%i" . /scratch/bfriesen/build/rsync-3.0.3pre2/testtmp/hardlinks/to/ 
rsync: Failed to exec support/lsh: No such file or directory (2)
rsync error: error in IPC code (code 14) at /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/pipe.c(84) [sender=3.0.3pre2]
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at /home/bfriesen/src/network/rsync/rsync-3.0.3pre2/io.c(635) [sender=3.0.3pre2]
----- hardlinks log ends
FAIL    hardlinks
PASS    itemize
PASS    longdir
PASS    merge
PASS    missing
PASS    relative
SKIP    ssh-basic (Skipping SSH tests because ssh conection to localhost not authorised)
PASS    symlink-ignore
PASS    trimslash
PASS    unsafe-byname
PASS    unsafe-links
PASS    wildmatch
SKIP    xattrs (Rsync is configured without xattr support)
------------------------------------------------------------
----- overall results:
      27 passed
      1 failed
      9 skipped
------------------------------------------------------------
overall result is 1
gmake: *** [check] Error 1
Comment 1 Wayne Davison 2008-05-17 16:49:59 UTC
*** Bug 5472 has been marked as a duplicate of this bug. ***
Comment 2 Wayne Davison 2008-05-17 16:50:54 UTC
*** Bug 5473 has been marked as a duplicate of this bug. ***
Comment 3 Wayne Davison 2008-05-17 17:00:18 UTC
Looks like you're building in a directory outside the source dir, which I hadn't checked recently.  Changing the SSH setting should fix this:

-SSH=support/lsh
+SSH="$scratchdir/src/support/lsh"

I'll fix the egrep errors next.