Bug 5445 - smb.conf.5: online HTML copy is missing parameter names
smb.conf.5: online HTML copy is missing parameter names
Status: RESOLVED DUPLICATE of bug 5439
Product: Samba 3.0
Classification: Unclassified
Component: Docs
3.0.28a
Other Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba Documentation QA Contact~
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-06 15:42 UTC by Patricia Dunkin
Modified: 2008-06-10 08:44 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patricia Dunkin 2008-05-06 15:42:18 UTC
In the version of smb.conf.5 available on the samba.org website as of today (6May2008), most of the parameter name labels are missing in the section titled, "EXPLANATION OF EACH PARAMETER".

Example: According to the troff source file for the man page taken from the samba-3.0.27a distribution, the first few lines of this section are:

.SH "EXPLANATION OF EACH PARAMETER"
.PP
abort shutdown script (G)
.RS 3n
This a full path name to a script called by \fBsmbd\fR(8)
that should stop a shutdown procedure issued by the
shutdown script.

When I process this with nroff -man on a Solaris 7 system and remove the
control characters, the above looks like:

EXPLANATION OF EACH PARAMETER
       abort shutdown script (G)
          This a full path name to a script called by smbd that should stop
          a shutdown procedure issued by the shutdown script.

Note that the parameter named on the line with the .PP macro appears just above and slightly to the left of its description.  The man page currently viewable at
<http://us1.samba.org/samba/docs/man/manpages-3/smb.conf.5.html> looks like:

EXPLANATION OF EACH PARAMETER

    This a full path name to a script called by smbd(8) that should stop a shutdown procedure issued by the shutdown script.

The name of the "abort shutdown script" parameter is missing, as is true of most other entries in this section.

Selecting View=>Page Source when displaying the smb.conf man page with Firefox 2.0.0.14 shows that the parameter name is missing in the HTML file:

<div class="refsect1" lang="en"><a name="id325432"></a><h2>EXPLANATION OF EACH PARAMETER</h2><div class="variablelist"><dl><dt></dt><dd><p>This a full path name to a script called by <a class="citerefentry" href="smbd.8.html"><span class="citerefentry"><span class="refentrytitle">smbd</span>(8)</span></a> that
	should stop a shutdown procedure issued by the shutdown script.</p>

The problem is observable in both Firefox 2.0.0.14 and Internet Explorer 6 on a Windows XP Pro system.

In the grand scheme of things, this won't crash any systems, but it limits the usefulness of this copy of the smb.conf(5) man page.

It's been a while since I've done much with troff/nroff, but it looks like the .PP macro used in generating the HTML may have gotten corrupted so that it's commenting things out rather than displaying them with a slight left hanging indent.

Thanks!
Comment 1 Karolin Seeger 2008-06-10 08:44:40 UTC

*** This bug has been marked as a duplicate of 5439 ***