Bug 5274 - Windows XP Pro x64 unable to join domain
Windows XP Pro x64 unable to join domain
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-02-21 07:29 UTC by James Andrewartha
Modified: 2009-01-06 09:14 UTC (History)
3 users (show)

See Also:

smb.conf of domain master (8.56 KB, application/x-extension-conf)
2008-02-26 08:12 UTC, James Andrewartha
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Andrewartha 2008-02-21 07:29:52 UTC
A freshly installed XP Pro x64 machine is unable to join our existing domain. Some packet captures: http://trs80.ucc.asn.au/charlotte-join-domain-3.0.28.cap (server is 3.0.28 testing package backported to Debian stable x86) http://trs80.ucc.asn.au/charlotte-join-domain-3.0.24.cap (server is 3.0.24 Debian stable x86) and http://trs80.ucc.asn.au/charlotte-join-domain.cap (server is 3.0.23 Blastwave on OpenSolaris). All the servers use the same LDAP sam database. Removing and adding an XP Pro 32bit client works fine.
Comment 1 Volker Lendecke 2008-02-21 07:41:35 UTC
For some reason XP disables the account explicitly after seemingly having joined successfully. See frame 332 in the 3.0.28 trace.

Do you have the chance to join against native NT4SP6a and send in a sniff of that?


Comment 2 James Andrewartha 2008-02-21 07:52:45 UTC
Sorry, we don't have any windows servers here. Both clients are SP2, fully patched. The error on the client is "The parameter is incorrect." for which the only possibly relevant search result is the messages around http://lists.samba.org/archive/samba/2005-May/105859.html 

You're right about the disabling, the machine LDAP account has "sambaAcctFlags: [DW         ]" afterwards.
Comment 3 Magnus Mertens 2008-02-26 07:34:08 UTC
I tried to reproduce the specified behaviour but a fresh windows xp pro 64bit workstation with the last patches joining to a samba 3.0.28 pdc worked for me.

It is possible to attach your smb.conf?

Comment 4 James Andrewartha 2008-02-26 08:12:27 UTC
Created attachment 3150 [details]
smb.conf of domain master

Here's the smb.conf. I found an old NT4 server at work, however it's not a DC so I'll have to reinstall it when I next get some free time.
Comment 5 Jez Tucker 2009-01-06 09:14:49 UTC
Duplicate of #4111 ?