Bug 4111 - Windows 2003 server R2 unable to join Samba PDC
Windows 2003 server R2 unable to join Samba PDC
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.23c
x86 Linux
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 10:09 UTC by Christian
Modified: 2009-08-24 07:29 UTC (History)
1 user (show)

See Also:


Attachments
smb.conf (1.58 KB, text/plain)
2006-09-20 07:11 UTC, Christian
no flags Details
smbd-log-lev10 (103.21 KB, application/octet-stream)
2006-09-20 07:14 UTC, Christian
no flags Details
Packet log of domain logon from client (PHOENIX) to PDC (BILL) (26.86 KB, application/octet-stream)
2009-01-06 08:56 UTC, Jez Tucker
no flags Details
Samba configuration file from PDC (BILL) (2.74 KB, text/plain)
2009-01-06 08:59 UTC, Jez Tucker
no flags Details
Windows XP64 Client (PHOENIX) debug log of domain logon (4.43 KB, text/plain)
2009-01-06 09:02 UTC, Jez Tucker
no flags Details
Samba log (-d 10) of XP64 Client (PHOENIX) trying to join to PDC (BILL) (87.77 KB, application/octet-stream)
2009-01-06 09:05 UTC, Jez Tucker
no flags Details
Packet log of domain logon from client (PHOENIX) to PDC (BILL) (26.86 KB, application/octet-stream)
2009-01-06 12:04 UTC, Jez Tucker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2006-09-19 10:09:01 UTC
I am trying to make a windows 2003 server R a member server of a Samba PDC Linux FC 4, kernel 2.6.16-1.2069). However, when I try to join the domain, I have the following error msg :
"invalid parameter".
I have submitted the pb to the samba mailing-list that advised to open a bugtrack.
I have absolutly no problem to join other windows XP or 2000 machines.
I have upgraded to samba 3.0.23c but it did not solve anything. I am using the smbpasswd passwd backend.
Windows 2003 debug file yields this :

08/22 18:06:11 NetpDsGetDcName: trying to find DC in domain 'NEOT', flags:
0x1020
08/22 18:06:19 NetpDsGetDcName: found DC '\\ADMIN-PDC2' in the specified
domain
08/22 18:06:19 NetpJoinDomain: status of connecting to dc '\\ADMIN-PDC2': 0x0
08/22 18:06:19 NetpGetLsaPrimaryDomain: status: 0x0
08/22 18:06:19 NetpGetNt4RefusePasswordChangeStatus: trying to read from
'\\ADMIN-PDC2'
08/22 18:06:19 NetpGetNt4RefusePasswordChangeStatus: RefusePasswordChange
== 0
08/22 18:06:19 NetpLsaOpenSecret: status: 0xc0000034
08/22 18:06:19 NetpGetLsaPrimaryDomain: status: 0x0
08/22 18:06:19 NetpLsaOpenSecret: status: 0xc0000034
08/22 18:06:20 Failed to validate machine account for OFFICE1 against
\\ADMIN-PDC2: 0xc000006d
08/22 18:06:20 NetpJoinDomain: w9x: status of validating account: 0x52e

- Then apparently, as it did not found a valid machine account, it tries
to create on but fails (one is already present)

8/22 18:06:21 NetpManageMachineAccountWithSid: NetUserAdd on
'\\ADMIN-PDC2' for 'OFFICE1$' failed: 0x8b0
08/22 18:06:21 NetpManageMachineAccountWithSid: status of attempting to
set password on '\\ADMIN-PDC2' for 'OFFICE1$': 0x0
08/22 18:06:21 NetpJoinDomain: status of creating account: 0x0
08/22 18:06:21 NetpGetLsaPrimaryDomain: status: 0x0
08/22 18:06:21 NetpSetLsaPrimaryDomain: for 'NEOT' status: 0xc000000d
08/22 18:06:21 NetpJoinDomain: status of setting LSA pri. domain: 0x57
08/22 18:06:21 NetpJoinDomain: initiaing a rollback due to earlier errors

Apparently it fails with this LSA domain stuff.
then it disables the account :
0
08/22 18:06:21 NetpGetLsaPrimaryDomain: status: 0x0
08/22 18:06:21 NetpManageMachineAccountWithSid: status of disabling
account 'OFFICE1$' on '\\ADMIN-PDC2': 0x0


=> I know however that the machine name is found in smbpasswd file :

"[2006/08/22 18:07:02, 10] passdb/pdb_smbpasswd.c:smbpasswd_getsampwnam(1339)
  getsampwnam (smbpasswd): found by name: office1$"

I really don't know what to do to solve this problem.
Comment 1 Volker Lendecke 2006-09-19 10:49:47 UTC
We need your smb.conf and a full debug level 10 log of smbd that your box joined against.

Volker
Comment 2 Christian 2006-09-20 07:11:51 UTC
Created attachment 2146 [details]
smb.conf

My current smb.conf
Comment 3 Christian 2006-09-20 07:14:54 UTC
Created attachment 2147 [details]
smbd-log-lev10

full smbd debug file (lev. 10) in zip format
Comment 4 Christian 2006-09-20 07:16:27 UTC
Hello,
I have attached smb.conf and smbd debug files.
Comment 5 Christian 2006-10-16 08:26:04 UTC
Can you confirm this is a 'bug' ? I need to know if I must work on my side to solve the problem or just wait for a new Samba release.
Thanks for your help.
Comment 6 Jez Tucker 2009-01-06 08:52:03 UTC
I can confirm this also occurs with Windows XP64 SP2, using Samba 3.0.31-0.fc8.
I have attached several log files, prefixed with jez_ to differentiate.

Please ask for any further relevant information you require.

Jez

Comment 7 Jez Tucker 2009-01-06 08:56:55 UTC
Created attachment 3854 [details]
Packet log of domain logon from client (PHOENIX) to PDC (BILL)
Comment 8 Jez Tucker 2009-01-06 08:59:08 UTC
Created attachment 3855 [details]
Samba configuration file from PDC (BILL)
Comment 9 Jez Tucker 2009-01-06 09:02:54 UTC
Created attachment 3856 [details]
Windows XP64 Client (PHOENIX) debug log of domain logon
Comment 10 Jez Tucker 2009-01-06 09:05:37 UTC
Created attachment 3857 [details]
Samba log (-d 10) of XP64 Client (PHOENIX) trying to join to PDC (BILL)
Comment 11 Jez Tucker 2009-01-06 12:04:09 UTC
Created attachment 3858 [details]
Packet log of domain logon from client (PHOENIX) to PDC (BILL)

File extension was not correct.  Replaced earlier upload.
Comment 12 Karolin Seeger 2009-08-24 07:29:04 UTC
As 3.0 is out of maintenance meanwhile and I am pretty sure that works fine with 3.4.0, I will close this bug report.

Please reopen if it's still an issue with Samba 3.3 or 3.4.

Thanks!