Bug 5122 - lib/replace/strptime.c: "rp_backup" and "era" set but never used
lib/replace/strptime.c: "rp_backup" and "era" set but never used
Status: RESOLVED WONTFIX
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.27
SGI IRIX
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
: 4585 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-05 14:19 UTC by Jason Mader
Modified: 2007-12-06 04:04 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Mader 2007-12-05 14:19:16 UTC
cc-1552 c99: WARNING File = lib/replace/strptime.c, Line = 255
  The variable "rp_backup" is set but never used.

    const char *rp_backup;
                ^

cc-1552 c99: WARNING File = lib/replace/strptime.c, Line = 267
  The variable "era" is set but never used.

    struct era_entry *era;
                      ^
Comment 1 Jason Mader 2007-12-05 14:20:28 UTC
*** Bug 4585 has been marked as a duplicate of this bug. ***
Comment 2 Volker Lendecke 2007-12-06 04:04:58 UTC
Well, I'm a bit reluctant to put a fix for this particular one in. Both variables _are_ referenced if _NL_CURRENT (whatever that is) is defined. You might want to provide a patch that wraps the variable definitions and assignments into #ifdefs as well.

But thanks for this report, keep them coming!

Volker