Bug 502 - 'net rpc user add' Creates Disabled Accounts on W2K
'net rpc user add' Creates Disabled Accounts on W2K
Status: RESOLVED DUPLICATE of bug 4098
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
All All
: P3 normal
: none
Assigned To: Guenther Deschner
Depends on:
  Show dependency treegraph
Reported: 2003-09-24 09:36 UTC by Joe Mondloch
Modified: 2006-09-13 11:58 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Joe Mondloch 2003-09-24 09:36:55 UTC
I ran into a problem attempting to create new remote users on a Win2k server via
the SAMBA net command. The users are being created, but the accounts are
disabled. After a few packet traces, I noticed that SAMBA is sending 0xe005000b
as the access mask. I successfully created a remote account using a VBS script
from Windows and noticed it used the mask 0xe00500b0 (last two hex digits
switched). Based on the comments in the below code, I'm wondering if this was
typo'd. ;) Unfortantely, fixing the mask isn't enough to fix the problem. I'm at
a loss as to what else is wrong. Maybe has something to do with the account
password not actually being set??? Doesn't look like the code is there to do
that yet...


python/py_samr.c:       uint32 unknown = 0xe005000b; /* Access mask? */
rpcclient/cmd_samr.c:   unknown = 0xe005000b; /* No idea what this is - a
permission mask? */
utils/net_rpc.c:        unknown = 0xe005000b; /* No idea what this is - a
permission mask? */
Comment 1 Guenther Deschner 2004-10-07 06:40:39 UTC
Could not be reproduced (using a win2k sp4 dc). The new account has no password
though and needs to give himself a password on first logon. Newly created
accounts were not disabled at least.

Please reopen, if you feel this is not correct.
Comment 2 Guenther Deschner 2004-10-07 06:49:23 UTC
arg. Too fast, "net ads user" is fine, "net rpc user" is *not*. Reopening.
Comment 3 Gerald (Jerry) Carter 2005-02-07 09:22:34 UTC
still a bug ?  (original report against 3.0.8pre1)
Comment 4 Gerald (Jerry) Carter 2006-09-13 11:58:57 UTC

*** This bug has been marked as a duplicate of 4098 ***